Cubase 11 Artist with Komplete Kontrol

All the lights, on my Komplete Kontrol S88 Mk2 go out when i start Cubase 11 Artist. Everything is fine with KK when i start it as a standalone.
My Computer information is :
Windows 10 Professional (x64) Version 2009 (build 19043.1415)

Dell Inc. OptiPlex 7020 00

16290 Megabytes Usable Installed Memory

Intel(R) Display Audio
Komplete Kontrol MK2 MIDI
Realtek Audio

3.30 gigahertz Intel Core i5-4590
256 kilobyte primary memory cache
1024 kilobyte secondary memory cache
6144 kilobyte tertiary memory cache
64-bit ready
Multi-core (4 total)
Not hyper-threaded

Has anyone had this problem, and know the solution?

What you mean with all lights? Does the power stay on?

I mean the keyboard goes dark. The power stays on, but it disconnect itself from Cubase. The keyboard works perfectly as a standalone.

Did it ever work with Cubase?

Yes, when i initially installed them. This became a problem about a month ago. I was working on something, and suddenly the keyboard went dark. I’ve tried running them with the anti virus turned off, I’ve tried running it in Safe Mode. They’re just not talking to each other now.
When i turn on the keyboard, and start Cubase The Pitch & Modulation Wheels work &
The two screens are on, but stay on the initial screen.
The Transport Section, Perform & Edit, Solo & Mute, Arrange, Control Section, Navigation & Mode, Pre-set & Page Buttons are inactive.
When i load up KK in Cubase the KK box appear, and i can select and use items from Komplete 13.

How is it configured?
Can you show the setup pages from the Studio?

The second picture is for remote control … transport controls and knobs.
I think it should be connected. But I’m not sure.

Also DAW-1 should be an option but it doesn’t show in that menu. NI is not in Task Manager unless i start KK as a Stand Alone.

I’m away from home for an extended stay so don’t have anything in front of me right now, but you should have another driver for Komplete Kontrol labeled “Komplete Kontrol DAW” which is the driver you should use with Cubase. Since it’s not showing up, I would try uninstalling your current install of drivers, rebooting, then reinstall the latest driver to make the KK DAW driver available.

Thanks. I’ll give it a try, and let you know the result.

I couldn’t find the ‘Komplete Kontrol DAW’ driver, but i did find this solution on another website.
I think I figured it out – I renamed the following directory to Hardware_Old

C:\Program Files\Common Files\Native Instruments\Hardware

Then, ran the “NI Uninstall RegTool_64bit.exe” utility and selected “NIHostIntegrationAgent”

Then I ran the Komple Kontrol installer again, and that seemed to recreate the C:\Program Files\Common Files\Native Instruments\Hardware directory and reinstall the services
It worked. I kept it running for a couple of hours, (other solutions only lasted 3/4 mins), and it was still stable. I restarted the computer, and tried again, and it worked as it should.
Thank you for your help.

1 Like