Cubase 11 elements stopped working

I run Cubase 11 elements, but after the last microsoft windows update it stopped working.
What can i do?



Hi and welcome,

Could you be more specific, what does it mean “it stopped working”, please? Can you start Cubase? Is there any message? Can you load a project? Can you playback the project? Do you get a sound?

I also had that a while ago It was because the license had problems after the update. But there are certainly more reasons. If you describe your problem in more detail, that would certainly help.


If this is the eLCC error, then start eLCC application as administrator and trigger the Maintenance, please.

I started Cubase and the following thing happened.

The activationcode could not be identefied. Please make sure that it is typed correctly.

After this i served to the website, they gave me a code, did everything they asked. But i ended up with the question to enter a dowlaod acces code to get activation code.

Please help me out!



Start eLCC application. Can you see the Cubase license there, please? Is it activated?

I think it’s activated. There is this picture of a harddisk and next to it is this serial code which is bound to my pc it says. I hope that this is what you mean.


Can you see the license on the right side, please? What license exactly, please? Could you attach a screenshot of the right side of the window, please? If you are going to attach the whole window screenshot, maje sure the Soft-eLinceser Number is blurred, please.

Sorry i try to upload a jpeg file, but it seems not to work.
I will discribe what i see on the left abd right side.

I see a bunch of keys and next to it My licenses
Below that we have a picture of a hard disk and next t it a code
Under this i see softi-eLicenser (SeL)
On the right site we have one key and next to it Cubase Elements 11
Under this it saysSteinberg, SeL

This what i see.


Is the Cubase Elements 11 text on the right side black or red?

Are you sure you have installed (and you start) Cubase Elements, please? Isn’t it Cubase Artist or Cubase Pro by accident?

The text is black and i’m very sure we’ve installed a Cubase 11 elements version.


You are allowed to upload a screenshots, now.

Could you please upload a screenshot of

  • the eLCC application > right part of the window
  • Cubase icon (with its name) you click to, once you start Cubase.

E-License Cubase

Here you have a screenshot of the ElCC.
I’m sorry but i can’t send you a screenshot of the Cubase icon, once you start cubase.
This because i de-installed the program after the probems started. I tried to re-instal it with
the help of (this is the shop where i bought cubase), but after installing the following screen appeared.


What happened, if you installed Cubase manually, please?

As i just said in the last message. I tried to re-instal the program. But the activation code works only one time. I made screenshots during this proces and will attach them all. Maybe it will help.