Cubase 11 Freezes, safe mode says MMDevAPI.DLL

I’ve been having issues lately:

Changing tracks while playing a song can cause the VSTs to stutter for a moment.

Sometimes when I’ve had a VST’s window open, the audio performance goes through the roof even though it’s not playing. Playing is even worse causing a lot of stuttering from increased load my PC can’t handle.

Right clicking on something like my Windows mixer while a project is playing, even if it has nothing in it as a new blank project, causes Cubase to freeze for a few seconds then just crash to desktop with no error message nor notice.

EDIT: Actually Cubase just crashes if I right click on my Windows mixer taskbar icon at all, but everything else seems OK for right click.

In the case of right clicking, when I open Cubase again and it asks about safe mode, it says it terminated due to MMDevAPI.DLL


Try to reinstall Cubase. Make sure you install it as administrator, please.

I downloaded the installer from the Steinberg download assistant as admin and then manually ran it as admin to ensure it would reinstall as such, but right clicking windows volume mixer still causes Cubase to freeze for a while then close.


Could you try to download the MMDevAPI.dll from Microsoft website and install it again, to make sure, it’s installed properly, please?

I can’t find a download for it because Microsoft is Microsoft. I however found that it’s loading MMDevAPI.DLL from the SYSTEM32 folder. Maybe this is the problem? I know 32-bit DLLs don’t work in 64-bit programs no matter what they are, aside from bridging options. I have the 64-bit version of MMDevAPI.DLL, so I have no clue why it would be trying to load the SYSTEM32 one.


32-bit driver (of any device) could load the 32-bit MMDevAPI.DLL.

So is there anything else I can try to fix it?


Something like Repair Windows? I don’t know, how to find out, which driver could use this library, sorry.

lol at this point I just automatically assume anything like this is because of a Windows 10 update with Microsoft’s track record in recent years. I’ll try to figure out something and post the solution if I ever find it in case others have this problem.

It seems after some updates to Windows and my video card that the issue has stopped. At least for now. Will have to see in the coming weeks if it stays this way.

1 Like