Cubase 11 & Kontakt 6, with real time audio hitting the max?

Hi friends,

I have serious problems in Cubase 11 Pro with Kontact 6, due to “Real Time Audio Processing” reaching 90% load! This applies when “Record Enabled” is enabled, which is standard in Cubase. But, if I deactivate “Record Enabled” then the load on “Real Time Audio Processing” goes down to only 5%, but then you can not work as you can not hear the VSTi instruments play the tracks without first activating the Record button.

So what could the problem be? :disappointed:

The configuration in my PC is:

-Cubase 11 Pro
-Win 10 Pro
-Kontact 6
-COMPLETE 13 -ULTIMATE Collector’s Edition
-CPU i9-9900K
-64 Gb RAM
-M2 NVMe drives
-Sapphire Radeon RX 5700 XT 8GB Nitro + OC
-Motherboard Gigabyte Z390 AORUS MASTER

Kontact 6 is configured with “Multi Processor Support = 8 Cores” as my computer’s CPU has 8 cores.

Cubase VST ASIO system is set to 256 buffers, 32 bit float processing precision, Activate Multi Processing = Checked, Activate ASIO Guard = Checked and in Normal Mode, Steinberg Power Scheme = Unchecked as I manually already set the computer’s power schedule to max CPU power and disabled USB power, drive and scrren pauses etc.

I have also tried to both change the driver on the graphics card from Radeon to MS Standard, but it did not help. I also tried turning off Hyper Threading in BIOS, but it did not help either.

Now I need your help, what do you think the problem may be due to, and what can be the solution? That would be a true christmas present :slightly_smiling_face:

Please watch my movieclip that describes this more in detail, and click the cogwheel and select 1080HD resolution below the clip, if it is started in blurred vision: https://1drv.ms/v/s!Ah3sl9-ke78wlHhmVNxllPwcKoVk?e=IFP61K

Thanx in advance! :santa:

Hi Jiwisto

Some Kontakt instruments are very CPU heavy - even if you have a well optimised and powerful system. The reason it goes down when you don’t have ‘record enabled’ is because of ASIO guard.

Does this happen with ALL kontakt instruments ?
When you don’t use Kontakt what does your ‘Real Time Audio Processing’ meter look like ?
Do you have overload issues with other plugins ?

It is sometimes better to have MULTIPROCESSING OFF in kontakt when used as a PLUGIN - so check it both on AND off.

Not to all instruments, like Etera Cinema Vocals it happens not since it only used aprox 5%, but It seems to happen to the piano like “The Grandour” since it triggers the “Real Time Audio Processing” up to 15-18%, wich is really strange I must respond :roll_eyes:

When I dont use Kontakt the “Real Time Audio Processing” is absolutely lower, about 20-30% load
when I use only Halion 6 and Steinbergs HSO (Halion Symphonic Orchestra), it only uses like 20-30% insetad av Kontakts 50-90%
I tried Kontakt with MULTIPROCESSING OFF, it did not change anything…still the same huge “Real Time Audio Processing” :thinking:

Thanx for trying helping me out Dr.Strangelove…

I just loaded up The Grandeur on my system: Kontakt 6 / Cubase Pro 11 / Win 10 (1909) and found the Audio Processing usage quite low:

that’s what I’d expect (depending on buffer size and if it was ‘input monitor’ / asio guard etc)

wonder if it’s worth going down the latencymon route ?

for completeness’ sake, here are my Audio Settings:

If it’s a general latency problem, typically I’d expect Audio Processing usage to be problematic across numerous plugins.

It’s quite unexpected to have a sampled piano trigger high Audio Processing . If anything, I would expect it to stress Disk I/O first.

After changing Kontakt to eliminate multi-core processing, just to be sure, I might want to at least reload Kontakt, maybe better restart Cubase and maybe best: Restart computer :smiley:

@Nico5

just feel like 20-30% load is a bit high for an emptyish project…

Don’t actually think it’s a latency thing as that would be more spikey but something not very optimised …don’t know what the audio card is so just random guesswork (as usual :slight_smile: )

That depends if it’s a truly empty project or if there’s lots of active plugins (possibly even in FX groups).

So the right thing for troubleshooting might be to start with an Empty Cubase project (from the builtin Empty template), and check Audio Processing load.

If it seems high with an Empty project, then I’d suspect a system wide problem indeed.

so many questions :grinning:

2 Likes

Troubleshooting is an underappreciated art-form :nerd_face:

1 Like

Thanx Nico5,

Just tested it myself, this time with Cubase own template, called “Empty”, and found out the usage was very low, lower than on your screenshot, så it seems fine so far…why do 13 Kontakt VSTi than use that much?

I’m glad it’s lower on your lovely powerful CPU compared to my feeble little 7 year old i7-4930K – No need to gloat! (just joking!) :joy:


FX inside or outside of a plugin can run up the Audio Processing load. And many FX - especially older and VST2 (which Kontakt still is) - still use CPU resources, even when there’s no audio coming in.

Reverbs can be very CPU intensive. One option to lower CPU consumption by Kontakt might be to disable (some) Kontakt internal FX - and rather use Cubase FX routing (the newer included reverbs in Cubase are very nice and are generally amongst the more CPU friendly reverbs.).


Another trick to lower CPU consumption is to use reverbs in send busses (using Cubase FX Groups), so that the same reverb is used by several instruments and/or audio channels. That tends to use less CPU than many reverbs as Insert FX.

That’s because mixing is a much easier calculation for the CPU than calculating a reverb. – So mixing 13 channels into 1 reverb is less CPU work than calculating 13 reverbs and then mix.


And yet another performance trick for Kontakt (and other multi-instrument plugins):

Having many intruments in 1 Kontakt ends up all in the same CPU thread.

Sometimes that is necessary, because the instruments are part of a pre-designed multi-instrument - and they are sharing fx and specific routing inside Kontakt (for example a string section with violins, violas, cellos and basses may be pre-programmed that way).

But when you just want a new sound - also made by Kontakt - it can help to put that new sound inside a separate instance of Kontakt, so it gets to use a different CPU thread than the first one.

How many instruments inside 1 Kontakt are ok, depends on the single core speed of your CPU and on how complex the loaded Kontakt sounds are.

1 Like