Cubase 11 LE elicense error

Hi

I bought a license for Cubase LE 11 a few days ago but I can’t seem to register it. The Steinberg Download Assistant will recognize the download code but then after opening the “elicense control center” an error always pops up saying that there is a communication error.

I have Windows 10 and the latest version of eLicenser Control Center. I also tried running everything as administrator.

Please see the attached image:

By the way the “elicense control center” opens up in Portuguese (I’m in Portugal) even though my Windows is in English, sorry about that. Is there any way to set it to english?

Cheers and please help!

Hi,

Login to your MySteinberg account and put the Download Access Code there to generate the Activation Code, please. Then open eLCC application and enter the Activation Code here.

This is the old way, but it should work for you.

Hi Martin

Thanks for your help, unfortunately I got the same result:

I did exactly as you described: I went to the Steinberg site, MySteinberg account, then I put the download code I got there, got the activation code, and finally copy pasted it on the eLicense Control Center. Everything went smoothly apart from the final step, which produced the same error as before :frowning:

What else can I try? Steinberg won’t reply to my ticket, opened 4 or 5 days ago. It was just when browsing through these forums that I found out that Steinberg is always late answering questions (or never does).

Cheers,
Pipanni

Hi,

So it’s the very same message, right? Could you try to start eLCC as administrator, please? Make sure, there is no antivirus or Firewall blocking the communication with the server, please.

Hi

Yep, the error message is the same. I just tried again with the firewall turned off and in administrator mode and got the same result. Can you think of anything else? (thanks again, by the way)

Here’s some updates:

  • I managed to activate the license on my work computer, but how can I transfer that license to my DAW? It looks like I have to use the eLicenser Control Center for that but it refuses to connect when I’m in my DAW (same network).
  • I also tried different network connections, including a connection through my smartphone, but with the same result.
  • I also managed to change the eLCC language to english, the error message says “a communication problem occurred while accessing the license server”.

Still need help! :stuck_out_tongue:

Hi,

Does it mean, it’s other computer?

You can either Reactivate the license, but I’m afraid, you would get the very same error in the eLCC.

Or you can buy USB-eLicenser, transfer the license to the USB-eLicense. Then you can just plug the USB-eLicenser to any computer and start Cubase. Be aware, there is no way to transfer the USB-eLicense back to the Soft-eLicense.

Hi Martin

Yep, it’s another laptop I have, from the IT company I work for. It’s full of virtual servers, lots of heavy software and uses a private VPN, and yet eLCC works flawlessly! (by the way I also tried reproducing the same environment, VPN and all, on my DAW, but to no avail)

I would prefer not to use a USB solution, there’s too many horror stories about it, and besides I don’t want a big USB pen sticking out of my laptop, waiting to break.

I also tried restarting my DAW (laptop) in safe mode (with network) but I got the same result. Isn’t it possible to find out what’s blocking the damn eLCC from accessing the license server?

I bought this license for Cubase LE 11 on ebay. If I buy the full license for Cubase Elements 11 (download only, no USB key) will I just end up having the same problem?

Thanks,
Pipanni

Hi,

Sorry, I’m not Windows and network expert at all.

Unfortunately you would have the same problem, because the problem lies in the eLCC.

Is reinstallation of the system (clean Windows) an option for you by any chance?

Is the time and date correct? This can cause this issue if I remember correctly.

1 Like

Hi,

You mean the system time, right? You are right, it rings a bell.

Hi

Yes, the OS’s time and date are correct, I never changed them, they’re on automatic.

Martin, I could reinstall everything, but it would be painful and even more so if it doesn’t work. But I’ll do that as a last resort. Maybe try dual booting first and check if eLCC works on a clean Windows 10 installation.

In the meantime I discovered you can create a “support file” on eLCC, and I’m gonna attach that to my Cubase ticket, even though I’m just talking to myself there :frowning:

If you can think of something else to try please let me know!

Thanks

Might be 2 things still, the virus scanner (maybe with included firewall?) or windows firewall. You can easily disable windows firewall and most virus scanners can be put on hold for a while.
I am assuming internet is fully functioning in a browser.

Thanks vinark, I just tried it, turned off both the firewall and Windows Defender (the only antivirus I have) but I got the same error.

I’m currently creating a USB pen with Windows 10 and I am going to boot from it (not install it), to check if a clean installation will allow eLCC to work. This way I’ll know without having to reinstall Windows from scratch.

Thanks