Cubase 11 MIDI Exporting crash (using MIDI CC Ramp mode)

Well, after hours of testing, the bug is confirmed.

  1. Create an empty project, add a new midi track
  2. Draw some random midi cc in “Ramp/Curve” mode (notes not necessary)
  3. Export MIDI File, then you’ll crash.

Try if you have the same issue.


I’m exporting my project to MIDI as usual in Cubase 11.0.20 , then a crash message occur.

Error message

Then Cubase became unstable, and that corrupted midi file can’t be deleted or overwritten before quitting Cubase.
Sometimes I could hear a short glitch noise before the warning dialogue occurs.

This orchestra project has 60 tracks with lots of ramp/curve automation, and VEPro connected.
And there is only one tempo jump, but a lot of markers and signature changes.
“Deactive 3rd party plug-ins” in safe mode won’t help at all.

I’ve tried to spot on the specific track that cause the crash with conditions below:

  1. Just delete all Audio/Group/FX/VCA tracks - crash
  2. Just delete Tempo/Signature/Marker tracks - crash
  3. Delete everything, only leave one track with data (a woodwind MIDI which can cause crash) - crash
  4. Same as 3, but change MIDI CC type to “step” - crash
  5. Same as 3, then delete CC messages/expression map settings/Tempo/Marker/Signature tracks and move this track out of folder, then delete the folder - crash
  6. Same as 3, then copy/paste the block to a new blank midi track, delete the original one - crash
  7. Delete all blocks with data, leaving the tracks empty - SUCCEED but make no sense
  8. Open another project with same template preset - crash
  9. Remove my external instruments in -crash
  10. Create a new empty project and export some random midi data - succeed, of course
  11. Copy a midi block from bad track, creating a new empty project, then paste - still crash!

Holy tricky. Still can’t find the reason. My workflow with colleagues could become a nightmare if this keep happening.

I tried deleting my strings/woodwinds/brass/synth MIDI blocks, leave those tracks empty, only exporting my drum sets’ midi, and it succeeded. Shrinking the debug range at least.

MIDI export settings such as type 0/1, locator range, export markers…none of them helps.


Attach the mentioned *.dmp file, please.

Cubase 64bit 2021.5.31 (1.8 MB)
here it is


Thank you for the DMP file.

Is it always reproducible? Can you reproduce it with any MIDI file?

Could you attach a screenshot of the Preferences > MIDI > MIDI File > Export Options settings, please?

When exactly does it crash? Do you see the OS dialog, where do you want to save the file? Does this Export Options dialog appear?

Thank you for the details.

export options
As I mentioned in the latest edit, I found this issue caused by “Ramp/Curve” type midi CC.

I have no alternative computers to test deeper, but it’s clear that even a single slope of CC without any notes can lead to a MIDI export glitch.

I’ve changed every used CC curves into step mode, and finally succeed to export my project.
Hope this to be fixed in next patch soon.

My colleague test it in same situation, and his progress is ok.
I’m using AMD-5950X cpu (X570 board) and his is Intel-10920x (X299 board).


I cannot reproduce it neither. Thank you for the details.

Reported to Steinberg. Thank you.

Hi @T-Nymph . I had a look at your CrashDump. Is my assumption right, that you are sending MIDI Clock in Stop Mode? (please look at Main Menu/Transport/Project Synchronization Setup…/Destinations/“Send MIDI Clock in Stop Mode”). If so, please try to deactivate it and tell me whether this solved the issue. If this helps, there is a good chance, that the problem is solved in the upcoming Cubase 11.0.30, even if sending MIDI Clock in Stop Mode.

1 Like

Nailed it! Things goes right after uncheking every boxes in sync setup.
I just tried checking them again and export my curved midi, error message no longer occur.
Thanks so much!

p.s. I did use several synth as external instruments (such as roland se-02) in my project, maybe that’s where the glitch sound came from.

Great, thank you for the verification. :grinning: As mentioned: I think you can check these boxes in sync setup again after having updated to Cubase 11.0.30 (after it has been released). Cheers