Cubase 11 Project File Size Limit is only 4 Gigabytes Why?

Hi, I have Cubase 11 Version 11.0.41. Mac Pro 128GB RAM, 64Bit with Big Sur Version 11.6. I’m building a template. I need help to fix a problem. My Cubase 11 project file size is now 4.29GB. But when I add any more instrument tracks and save then exit cubase and then reload the file. The file is corrupt. I found that the file size limit for the last file was 4.29GB, if the file gets any bigger then 4.29GB Cubase 11 can’t read it and throws an error stating that the file is invalid. How do I get Cubase 11 to read a larger file then 4.29GB? What workaround is there to allow me to keep expanding my template?

Are you using Cubase to record audio data from astronomical telescopes? Why is it otherwise so huge? I think the hard disk must be formatted to a different type to allow single larger files greater than 4 GB (not sure on Mac) Regards.

1 Like

Suseka is most likely correct, what is your mac drive formated as?

Two Ways to Break 2TB File System Limit (

exfat - Getting around the FAT32 4GB file size limit - Super User


As far as I now, there is really limit of the CPR file size. What does your template contains, it’s so large?

The only explanation I could imagine… Some VSTis are saving its samples to the project. Arturia or NI Kontakt did it in the past, but it has been fixed (they shouldn’t do this, it’s a bug). Please, make sure, your plug-ins are up to date.

Audio files are not part of the CPR file. They don’t change the size of the CPR file. What would change the CPR file size is, if you would have huge number of small Audio Events…

is or isn’t?


Are you using Spectralalyers?

There’s this:
.cpr sizes go crazy (500mb) for simple unmix stems project - SpectraLayers - Steinberg Forums

1 Like

Hi Larry,

The file size is 4.29 Gigabytes that will load, but if the file increases in size beyond 4.29GB, the next time you try to load the file, it will say “Invalid Project File: ”

So, I created a video that will show you exactly what is going on. The video is only 5 minutes to help you understand the problem. Can you please take the time to view the video and then tell me what I should do to get around this problem please?

You Tube Video Link:


Hi Ryan
1 great video and very clearly spoken.
2. i have never used such a big project so i am not here to lend any kind of advice
however i would like to put a little feul to the fire if i may
you are using Audio files only ? correct ?
my question is if cubase hase a file size limit for projects , then what do the guys working with film scores do ?
they have audio and video files and that must be Enormously big
3 did you try starting a new project from scratch ( i know …that track count it will take days) ? the reason i ask is … if the basis or original file is corrupt then you may be wasting time adding to it
4 if you have time start a fresh and look what gives you the biggest file size spike …
5 could it be that the third party library(in the native instruments plugin) is causing the problem ??

anyway please keep posting on any progress (or non progress)
best of luck

does post pro version of cubase --NUENDO have a limit also ?
if so how do high end users work ?

Hi Tony,

I’m just adding multiple patches inside a Kontakt 6 player that is in each track. Each patch is a track instrument articulation if that particular instrument.
I was trained by my music teacher Guy Michelmore from England on this. It is a valid way to reduce the number of Kontakt player instances in the project which is needed so it will reduce the consumption of computer memory and CPU usage.

Basically it would not be good to put one patch per Kontakt player per track. If I did that I would have about 27000 tracks (Wow!). So this technique is most desired.

Yes, there is nothing else in the project file except these instrument tracks (e.g. No Videos, No WAV files, No Pictures or anything else.)

Can you and the team find out why I can’t add any more instrument tracks to Cubase 11 after the file reaches a size of 4.29GB? I believe this is a technical issue that needs to be addressed.

I know and double checked the technical specs on Cubase 11. It does not have any limits to instrument tracks (e.g. Logic Pro X limits to 1000 tracks). But there is something definitely wrong where the file size greater then 4.29GB is causing Cubase 11 to stop loading the file and throw an error of “Invalid Project”.

To answer your question, yes I started a new project and added my tracks to the new 11.0.41 project file. The results were the same where if I save and reload the file at the limit of 4.29GB, the file loads, but if I add more instrument tracks to increase the file size from 4.29GB to something greater, the next time I load that newer file that is greater then 4.29GB, Cubase 11.0.41 will throw an error saying “Invalid Project” and stop working.

I’m going through each question you are asking. Again, I started with a new project file but getting the same reproducible problem over and over again.

It’s not a third party library problem. I have added other libraries and had the same exact problem. I’m just using the Kontakt 6 player to house my patches.

I uploaded 2 files that I worked on that were in the video. Can you and the team please review the 2 files that I uploaded please? Can you also please involve other team members to find out why this is happening?


Hi Ryan
thanks for posting
firstly i must say i am not a member of the cubase team (i wish i was ) instead just a cubase end user like yourself.
i will however ask some friends that may have some ideas , but there is no one i know with more knowledge that i know of other than Martin (he answered early on in your post).
your Mentor is “Guy” ? wow he is truly Awesome.please say hi from me ( he wont know me but i watch his you tube stuff a lot … just great.
now as far as i know Guy still uses cubase … maybe you could ask him if he has this problem if so then it must be a problem that is global (not always a cubase problem) if not then it must be something you may have overlooked.
you might want to ask him if he would be willing to share one of his templates or at least let you see what his file sizes are etc.

i think if you are not in too much of a hurry with this problem you might want to wait until the release of version 11.5 has been and gone (after the usual teething probs of a new release is over) then write to the head office in Hamburg.
failing that… we do have GOD on our side… in the wonderful Mr . Greg Ondo… write to him and maybe he could look into this and possibly address the problem in his monthly cubase hangout on youtube
good luck Ryan
keep us up to date.


I have found a ticket in the Cubase’s bug-tracking system. The result of this ticket was:

the cpr format is limited to 4GB, exceeding that size is not allowed.
The problem only exists with Kontakt, the user has been prompted to contact Native Instruments.

Btw, originally the limit was 2.3GB, what has extended in Cubase 9.5.30 to the current 4GB limit.

1 Like

Thanks Martin for the useful information. Imho such technical details should be part of the knowledgebase / product documentation (i.e. in an appendix / technical information sheet).


One ‘workaround’ could be to use Vienna Ensemble Pro in your template.

It’s an extra layer of complexity, but it would allow you to host as many instruments as you like outside of Cubase, dramatically reducing the .cpr file size.

You could either host your entire template in VEP - bringing down the .cpr size to almost nothing, or just host enough instruments to prevent the error message.

You can also disable instruments in VEP too if you wish.

As I say, it’s not perfect as it sacrifices the simplicity of having everything inside Cubase.

1 Like

Hi Jon,
Yes, you are right! I forgot about my Vienna Ensemble Pro. I do have another machine with 32GB and do have Vienna Ensemble Pro. I forgot about this idea, thank you so much for mentioning it to me. This would cut down on the file size for the main CPR file so I can put some of my other instruments on the other machine. I guess I originally wanted to have one big nice beautiful template with everything in it. But your suggestion is the answer for 3 reasons. File size cut down, saving of computer memory and cpu resources by creating load balancing technique. This is great news! Ok, I’m back in the game again! :slight_smile:

Glad to hear it!

You could also still keep it all on the same machine and disable the VEP instances, maybe put your least used instruments in there?

Hi Jon, Yes I plan to offset the load by putting less used instruments on the other computer. Then, I’ll be in great shape. :slight_smile: Thanks again!

1 Like

Also, using VEP for libraries you don’t need to tweak (de-couple) makes for way quicker Cubase save/load times. And, I actually have a huge VEP template on the same computer as Cubase, works great!


Official bug report has been created in the NI Kontakt bug tracking system.