Cubase 11 Score Editor - "Select All" + Action doesn't apply to "all"


I have encountered the following issue while transposing whole staves one octave up or down after importing XML.
In the score editor, I use Ctrl-A to select all notes on the staff.
Then I use Ctrl-up or Ctrl-down to transpose one octave up or down.
Everything seems to be working fine, but later on I find out that the notes that were not visible in the score editor window at that time were NOT transposed.

So basically, Ctrl-A then Action only applies to visible notes, which is very unexpected!
The score is quite long and I really need a way to select all notes on a staff. Ctrl-A should do it, shouldn’t it?

Thank you for your help!


Were the other notes “hidden” because they just don’t fit to the screen? Or were they hidden other way?

Are you in the Page Mode or not?

So far, I cannot reproduce it, it works as expected to me. All Notes are selected.

Hi Martin!

You’re right I didn’t give enough context. I’ve just reproduced the bug to give you all the details.
The issue happens in Edit Mode in the Lower Panel and in Edit Mode in the full Score Editor window.
– I use Ctrl-A to select all notes. If I scroll along the staff, I can see that all notes are selected.
– Then I use Shift-up to transpose all notes one octave up.
→ Only the notes that are visible in the Score Editor window at that time are transposed.
If I scroll, I see that all notes are still selected. But the action only applied to the visible notes.

And yes the notes are not visible because they’re simply further away, they are not “hidden”, just outside the window.

I hope it helps!

Hi @Esther_Gagne , I can confirm the behavior described.
Only the notes on the currently visible page are transposed, although the notes on the other pages were also selected!

The workaround is to be aware of this behavior, but…
A Logical Editor preset will transform the notes on the other pages as well. So, if you really need this, create two macros similar to the one in the screenshot below. Please note that in the second LE preset you need to replace “subtract” with “add” — in the operation column).

Logical Editor - screenshot

After creating the LE presets, you can assign the same key combination that you use now.
LE preset one = shift+up
LE preset two = shift+down

Thank you very much for your input!
I found another workaround in the meantime, which is a bit simpler for me :slight_smile:
I switch to the key editor in the lower panel. When in the key editor, Ctrl-A then Action applies to all selected notes.
I then switch back to the score editor to continue working on the part.

So I guess this will do for now, thanks!

That’s how I always do it: I do everything in terms of note and rest length, position, etc. in the key editor. I only make visual changes in the score editor.
Nevertheless, I would describe the behavior described by @Esther_Gagne as a bug, because it contradicts the rules that apply everywhere else.
A command should basically affect all selected objects and not just the currently visible ones.

In the Score Editor instead of Shift+Up/Down arrows, use the Pitch setting in the Info Line.

Yes, this works for all selected notes.
The question remains why Shift + Up / Down only works on the current page …

Thank you @Maestro I’ll try that too, I like the idea of staying in the score editor!


Reported to Steinberg. Thank you.