Cubase 12.0.20 performance issues

Hi @J_Shizzle ,
happy to hear you mostly enjoy Cubase 12.
Regarding Halion Sonic SE: does the same synth also smash your CPU, when running in Cubase 11 (in case you are on a M1: please enable Rosetta mode for both, to be able to compare C11 and C12)?
Thanks for letting me know.

Hey there,
I don’t own cubase 11. But the same Projekt with the same synths in cubase 10 is totally fine

Hi Chriss. Thank you for replying. I’m using 100% scaling in my display settings. I hope good news in the next fix. Thanks Chriss.

1 Like

Personally, I think it’s a really good idea… I think a lot of people would buy this equipment and at the same time many of the problems raised on this forum would disappear… In fact there would have to be strict guidelines for the hardware itself and all software settings i.e. drivers, BIOS, Cubase but I think this is not a problem for Steinberg… Maybe we will see such a solution in the near future…

Could you please sent me your plug-in report from the project you are mentioning?

Hi @Tony_ST ,
you described an issue where you experience a short pause on an added Midi track. It is probably a known issue, where disableing Monitoring/ Rec-Arm on VSTi + Midi tracks leads to a short interruption, if your buffer size is the same as the Asio guard latency.
A fix is scheduled for one of the next updates. As workaround, you can make sure to keep your audio buffers like this (for 44 & 48 k, if you are on 96k, just double):
Asio Guard Low: buffer size < 256
Asio Guard Normal: buffer size < 512
Asio Guard High: buffer size < 1024
I hope this helps for the moment.

1 Like

Thank you very much Chriss.

Same for me! C12 performs bad and strange, C11 works fine.


Some re-sizable VST3 plugins still produce some internal errors and can even show error messages within Cubase when we resize them.
It does that mainly on plugins that can be resized by a factor scale from within the plugin itself, for example a slider or anything that you can scroll with the mouse.
I really believe that the VST3 resize handling/communication between the plugins and Cubase has been broken with the C12 release.

Here’s the Crash Dump I just got :
Cubase 64bit 2022.5.7 (888.9 KB)

Also here are two other Crash Dumps which I didn’t remember what I’ve done to get them :
Edit : These are from an Audio Alignment bug, and this has already been reported to Steinberg.
Cubase 64bit 2022.5.1 (769.7 KB)
Cubase 64bit 2022.5.2 (681.3 KB)

Hi. I got here by googling ‘cubase 12 dropouts’ which I’m experiencing, which lead me to the thread for v12.0.10 which I read in its entirety. I realized I was using 12.0.20 so I’ve read this. I’m still experiencing significant dropouts in a simple project with a single track using Halion acoustic piano bright. The dropouts make it unusable. I’ve run 11 on this same setup with no issues. I’ve tried to make the adjustments I’ve read about and nothing helps.

What’s particularly interesting to me is that the issue is definitely cumulative. I play, it sounds great, after a few bars it starts to clip. I sit down and read the forum, make an adjustment, it gets better I think ‘great I solved it’ - and it comes back. I finally realized that if I just let it sit for 30 seconds, it’s gets better, for about 30 seconds.

I’m running 12.0.20, I’ve got an R16 interface, the computer has in i7 @3.6 gig with 4 physical (8 virtual) processors. 32 gig of memory and only SSD. I have this issue with two different MIDI - USB interfaces.

Way back when I first got into this, I remember resolving by getting a better midi-usb interface from Yamaha, but I don’t remember the cumulative effect. Let me know what I’m missing here, thanks,


Would be interested to know if it’s just me, or has anyone else observed this?:

Once glitching kicks in, CLOSE Cubase (12) and switch to any YouTube video (already opened but not playing) which has background music in the video (I use a FireFox browser), Even though C12 is closed, YouTube audio glitches in exactly the same way as it did previously in, the now closed, C12.

Context: I have only one audio interface running on the Laptop (ThinkPad through a Yamaha THR30), all other audio interfaces (inputs and outputs) are disabled within WIN 10 settings, including the built-in laptop audio.

Reboot WIN 10 and audio is glitch-free again within YouTube and C12 playing the same project.

So is this a single, initialising, unrecoverable, (unknown) event within C12 LATCHING the (Yamaha THR ASIO) audio into a semi-permanent glitched state, that only a reboot of (up-to-date) WIN10 can resolve?

Anyone else observed this? Or is this to be expected, and I’m reading too much into this?

Please add some more details to your reports. Unfortunately „bad and strange“ isn’t helpful. Please describe how the performance has changed and add a plug-in report to let us know about the specs of your system. It‘s not a general issue. Cubase 12 is performing very well on the majority of systems. That’s is why it is so important to understand the context on which system the issues occur. Thank you!

Could you please sent me your plug-in report? We would like to know the exact specifications of your CPU and that’s in the report.

Hi Matthias, thank you so much for your quick report. I’ve attached the report.

I had associated this issue with the upgrade to Cubase 12, but I only notice it with the piano instrument both using Halion and A Roland plug in that I use. And I just resumed playing piano recently. I have not tried it on v11 and I have upgraded my computer to one with more memory and all SSD. So a few things have changed since this last worked and it may not just be v12. Either way, I’m hoping you can help me and thanks again,


ps, wasn’t sure what to do with the plugin report; this forum didn’t accept a .txt file so I just renamed it to a .crash file but it’s just a flat file.

Di LoretoPlug-in report.crash (30.4 KB)

In addition to my earlier report (4770k, Win 10, RME HDSP8652)
The more I use 12.0.20 the more frustrated I get. I’m getting daily ‘hangs’ in the same semi-predictable ways I never did with C11.

  1. Inserting a plug in an insert or send slot.

  2. render in place of any MIDI event.

I’ve gone to reflexively saving right before doing either of those tasks.

When I re-start, it gives you the chance to send a log to SB, but the cause is always ‘freeze’ which doesn’t make sense.


With the new Melodyne update in Cubase 12.0.2 is no change in my errors

  1. applying Melodyne via ARA on a event - new recordings on this audio Track is impossible
  2. if Melodyne is applied on vocal events - its sounds glitchy , shifted not natural
    in cubase 11.0.41 everything is cool


then ever I close a project - cubase is hangin :frowning:

my system
MAC OS Monterey
12.3.1 (21E258)
Mac (Retina 5K, 27 Zoll, 2019)
3,6 GHz 8-Core Intel Core i9
24 GB 2667 MHz DDR4

I have similar issues here. While the 12 release started quite well for me for the last 2 days its been quite bumpy (but i do admit i had much more work in the last 2 days). Im on windows 11. Crashing and freezing:

  1. open older session- crash (almost every time)- cubase has stopped working message
  2. Try to create a new project- hard freeze solvable only by ending process in the task manager (half the time)
  3. Mixdown a project and try to quit- hard freeze with a zipper stuck noise solvable only by ending process in the task manager (every time)
  4. Start Cubase- hard freeze on Loading Chord Pads (occasionally)
  5. Start cubase - Hard freeze on Scanning VST3 (occasionally)
  6. Trying to copy inserts in the mixer (native and 3rd party) Hard freeze again (half the time)

ive counted more that 30 crashes in the event viewer
Unfortunately there is no crash dumps created. The only report i see is in the Event Viewer:

Faulting application name: Cubase12.exe, version:, time stamp: 0x6262c0c5
Faulting module name: ntdll.dll, version: 10.0.22000.527, time stamp: 0x931cda92
Exception code: 0xc0000005
Fault offset: 0x000000000003929c
Faulting process id: 0x15f0
Faulting application start time: 0x01d862cb1477dd04
Faulting application path: C:\Program Files\Steinberg\Cubase 12\Cubase12.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: aa45d5e9-f3b0-4e1e-8a49-f71fca154a35
Faulting package full name:
Faulting package-relative application ID:

Windows 11, both 12.010 and 12.0.20 Tried reinstalling and removing preferences no luck.
These issues happen randomly

Best Regards

In case you didn’t know that already, SD3 is VST3 since last week.

It doesn’t help with our issues though (I experience the same behaviour you reported). Chriss from Steinberg is aware of SD3 being a likely culptrit for our issue and is investigating that further.

I’m noticing that if I leave Cubase open for more than a few hours and then return that it consistently goes unresponsive. This will happen overnight, for example, if I put the mac into the Lock Screen and then return to it the next day, then I have to force quit the app and reopen it. I’m on an M1 Macbook Pro macOS Monterey 12.3.1.


I’m having the same issue. The upload tool in the forum doesn’t allow for uploading .txt files. See the attached image with the grayed out file for an example.