Cubase 12.0.20 - renaming files with a -01 when I hit Save?

I’ve been having an issue since moving to Cubase 12 on PC, Windows 11 - sometimes, when I hit Save, the .cpr file gets saved with a -01 appended to the end of the name.

This then confuses Cubase when I try and open a session from the launch menu and it can’t find it (Error message “File xxxxx.cpr does not exist. Do you want to remove it from the recent file list?”) because the name has been changed! Is there any way of preventing this from happening?

Thanks! Any help much appreciated.

Ctrl+S = regular save (overwrite)
Ctrl+Shift+S = incremental save (append digit)

You may want to double check your key commands as it sounds like you are doing an incremental save.

Also check your auto backup options in prefs fwiw.

Hi,

This is called Save as new version.

1 Like

This can’t be the problem, because the original file disappears, which doesn’t happen when a new version is saved.

1 Like

Yeah this is the thing - it doesn’t save a new copy of the file and increment the new file with a -01 version number, it writes over the original file…

Hi,

When Cubase is saving the project it always creates a new file (to have a backup - the old one - in case of any issue). Once the file is saved successfully, the old file becomes deleted and the new one is renamed.

So it seems, your new file doesn’t become renamed correctly during this process.

The question is: Why?

Would love to know as it’s still happening!

I checked and it’s definitely not Save as New Version - I don’t have a keyboard shortcut bound to this.

Might be a permission issue with the folder you are saving in. Check the properties of the folder and if on windows the security tab. User should have full write permission.

Thanks - have updated all the folders on my project drive to give Users write permission which was unchecked for me. Will let you know if that changes things!

(how can it even be saving any file if the write permissions are wrong?)

Well the hierarchy of permissions can be weird and messed up. Which is a common issue on mac, which have a command to fix permissions.
On windows it is not that common, but it does happen.

This is not that, actually. The Repair Permissions function on Mac looks at system files, not documents that programs create.

Here’s a quote from an (oldish) article about that in Macworld:

only those files installed using OS X’s Installer utility and whose installation packages leave behind a proper receipt in /Library/Receipts are affected by the Repair Disk Permissions function. This means that most of the files affected by the Repair Disk Permissions function are system-level files, application files, or system add-ons—not applications installed by drag-and-drop, and not your documents or other user-level files

I’m interested in what the solution turns out to be for the OP issue.

Hi,

This is not in the macOS for quite some time already.

1 Like

Hahaha as you can see I am a pure widows person (m/v), I will refain from mentioning anything about macs. But since the OP did not have write permission on the project folder, my guess could be right. The suspense…

Well - changing the permissions of the folder seems to have worked so far! Worked on Cubase projects all day yesterday and saved using Ctrl+S several times, and no sign of the -01 behaviour. Will update the thread if anything changes but thanks all for your help, really appreciate it.

Update: Damn - just as I thought it was working fine, it’s now just done it again. Back to the drawing board…