Cubase 12.0.51 crash - need to roll back to 12.0.50

Same here. Crashing when I tried to use Midi remote mapping for my Axiom 49. It also lost my previous mapping setup. I’ll try rolling back to 12.0.50 (if I can find it).

Hi all, we have analysed the issue and do confirm that it has been introduced with the 12.0.51 update. Please roll back to 12.0.50 while we’re working on a fix.

1 Like

If you have not deleted them you can find the installation files of previous versions in the Downloads folder of the PC

back to 12.0.50 and everything seems to be ok now :+1:

Unfortunately there is no V 12.0.50 to download…

Thats the problem :wink:
I updated directly from 12.0.40 to 12.0.51 - big mistake :wink:

See if you have the installation file of the previous version in your Downloads folder.
On Windows, search for downloads → Steinberg → Win64, on Mac download → steinberg → osx.


Rolled back to .50 and no crash now when pressing shift on LKMk3.

If you could fix the “shift+track” button behaviour at the same time, it would be appreciated. :slightly_smiling_face:

Currently, the shift+ track buttons (previous and next) applies to the folder header as well as the tracks within the folder - this makes the shift+track function confusing to use when in the mixer as there are no folders in the mixer! Maybe this is why it crashes in .51 - has SB tried to fix this issue and it didn’t work properly, hence CB .51 crashes when pressing shift? :thinking:

We’ll provide a direct download to 12.0.50 asap

cheers! :slight_smile:

Cubase Pro 12.0.50 can now be downloaded again.

where can i find ? 12.0.50

While this is not a “solution” – it is a link to the Cubase 12 Download page for the convenience of those who need to roll back to 12.0.50.


Thanks for letting the old version available.
To roll back do we have to uninstall Cubase 12.0.51 completely or we can simply launch the 12.0.50 installer over?

Both on Mac and Windows I uninstalled 12.0.51 and then reinstalled 12.0.50, no settings lost. :+1:

Thank U! :slight_smile:

This is why I love being a packrat and keeping all my installers… Haven’t run into any issues yet, but I do have a Launchkey 25 I use from time to time, so I rolled back to stay safe for now.

Just had to delete the .51 app on my Mac and reinstall .50, good as new again…

1 Like

By me the same problem with my Launchkey 49.

Reinstalling 12.0.50 solved the problem.