Cubase 12.52 - Performance Issues with recent W11 Update?

Hey guys

Just trying to narrow down what the problem is before rolling back. After recently updating, I’m having issues with CPU spikes (when loading instrument patches) and occasional crashes when performing actions such as; Enable / Disable Track, and Saving Track Presets

GUI Meters (on the secondary monitor) are also acting sluggish and slow - until they’re selected. Not had ANY of these problems prior to this.


Windows 11 - Latest build
GPU - Nvidia GTX 1070 - Using Studio Drivers
CPU - Intel 13700KF
RAM - 64GB 5800Mhz
Motherboard - MIS MAG Z790 TOMAHAWK WIFI
3x NVME - for OS, Sample Drives
2x SSD - Project Drive, Media
2x HDD - Cold Storage / Backups

Mouse - Kensington Slim Track Ball
Stream Deck XL
Komplete A49

Things I’ve tried in Windows

  • Trashed Preferences
  • Uninstalled and removed Cubase entries from Registry
  • Fresh Install
  • Updated Drivers for all peripherals and software
  • Changed Permission settings for Cubase to run as Admin
  • Checked my exceptions to ensure w/defender isn’t scanning specific folders
  • Under-clocked Memory and CPU - (made no difference)
  • Power Settings - I always set these to High Performance and disable any hard drives being turned off.
  • Set GPU to performance mode / along with Windows Scheme

In Cubase

  • Tried different ASIO Guard settings
  • Tried Enabling / Disabling Steinberg Power Settings
  • Tested plugins/samplers one by one by removing them from the VST directories and adding them back in.
  • Tried different buffer sizes (just for the sake of checking)
  • Tried running Cubase in 32-bit and 64-bit processing.

Regardless of project size, I get these random crashes happening fairly frequently that don’t provide an error code. Cubase just closes. Any suggestions I can try?

Have you tried running the license activation manager for any updates?

I had Windows update itself at the same time as a few other plug-ins here recently. It seemed to cause a few issues momentarily until I’d worked through and made sure everything was up to date which included the license activation updating.

After this recent update on my PC, I had to re-check some USB devices. Some appeared as ‘doubles’ in the device manager and I had to delete them. (as these seem to cause troubles)
You can check this in the device manager but make sure to ‘show hidden devices’.

Since Steinberg posted about having issues (on Facebook) with things. I hadn’t thought of checking it. Interestingly when I run eLicence as Admin, I get this pop-up error.

Will try reinstalling it now and see if that’s the medicine needed to solve the problems. As for the Activation manager, I can’t seem to sign-in. Might explain why.

Cheers for this. Just checked and it seems to have also duplicated some of my devices. Will delete them and see if that helps.

Are you not on a software license now? There’s an application called License Activation Manager now - I think it replaced eLicenser. That’s what I was referring to.

1 Like

Sorry, I got confused for a second - yes the C12 license is not using the dongle for activation. Although I still have the dongle plugged in.

Managed to sign into the Activation Manager now, it’s at version Just finished deleting the device duplicates too, will give it a test and see if I get the same problems.

There is an article on these recent CPU’s …

Ahh, well then. That could be the root of the issue - will read through it and see if the workarounds help… Cheers!

Is there a .dmp file created?
If yes, I’d contact support and meanwhile you could upload such a .dmp file on this forum.

Furthermore there is an article about optimizing PC’s on the Steinberg website.
I systematically set USB devices to this setting (in Properties > Power Management) wherever available:

Here is the article: