Cubase 12 bug with CSPM export!

If you are exporting group track that has an audio channel with send on it, and that send track is not routed to the main Stereo Out (if, for example, like me, you have all sends routed first to SEND GROUP), printed group will be without that send, meaning dry. Can we please get a fix for this because I’ve seen in the past year or so people would write about this, but no one from Steinberg would answer it. Please, this is a deal-breaker! And yes, I’ve tried solo-defeating everything!

No one? @Martin.Jirsak


Could you attach a screenshot of the Export Audio Mixdown window, please?

here are 2 screenshots, first is Mixdown window, and the other is mixer, so you can see the routing. The problem is, when I export the group which includes audio channel that has send, it exports without those sends.


Thank you for the screenshot. Actually I would say the feature is specified like this. With the Send it’s the parallel connection but the signal chain takes just the serial one.

Hi, sorry for late response, I had some private things going on that prevented me from investigating this further.
My response to you is that that is not true, as in the manual ( Export Audio Mixdown Dialog ) it clearly says:
“Includes insert effects, EQ, and other channel settings. Also includes effects and settings in all channels, for example, group and FX channels towards the output channel, and the insert FX and EQ settings of the output channels. The channel configuration is exported post-panner.”

This is a really huge thing for my workflow and I believe for many more producers, so I hope you can forward this issue to development team so they can fix it!

It works if you select only the audio track/instrument track, not the group to export.

I guess Cubase only looks for Sends for the channel to be exported, not any channel sends on previous channels from the signal path. Bug or feature? IDK.

Yeah, that works, but in my case I need to export groups because I’ve set up my groups as stems, so when I’m done with the project I want to be able to exports stems (all drums, all guitar, all keys etc.) with each send of the individual audio tracks included. I’m inclined to think that it’s a bug.

1 Like

I don’t think that it’s a bug. The wording is a bit unclear, but it states “ towards the output channel”, which I guess means “all the groups and effects starting from the selected channel”.

I personally route any effect return to the group where they belong to and not the main channel or some dedicated FX group. So “drum reverbs” to the Drum group, vocal verbs to the vocal group etc.

1 Like

Maybe that’s the fine print?

To me it seems logical that by exporting the AUDIO GROUP we don’t get any of the fx, I don’t know.

Not that it wouldn’t be nice to be able to bake those two groups together from the export window, it would!

1 Like

Thanks for the pictures explaining your logic, but when I solo the audio group in Cubase console, it also solos the fx, so I hear it, so by that logic I think that the export should function the same, no? Same as If going by hand and soloing each group individually and export everything one by one. Because soloing groups works as I think the export should work.

1 Like

I understand where you’re coming from, I really do. I cannot know if this is right or wrong behaviour, I just offer what seems more natural to me.

Personally, I don’t like it when 3 tracks are soloed at once just because they’re connected. I like to only listen to what signal gets through at one place at a time. (That’s why I use listen more than solo)

But as I said, since it does happen, I totally understand your wanting to have export perform in a similar way.

1 Like

The difference there is that when soloing im Cubase, everything still goes through the main out. When you’re exporting just the group, you specifically exclude the main out. So I guess the way Cubase does this might be a case of “works as designed”, but of course I understand that is not what you’d like it to be.
You could maybe rephrase this as a feature request, but tbh, I wouldn’t hold my breath for Steinberg to change this behaviour…

Maybe if you just tried what I suggested? Create dedicated sends for your stem groups, and don’t just collect all send returns on one channel.
From what I’ve read or heard, this is exactly how people who regularly have to deliver stems work, not only in Cubase.

I get what you’re trying to say and thank you for that suggestion, I definitely will be creating dedicated sends for time being until this is fixed, but you saying that when I’m exporting just the group I’m “specifically excluding main out” is simply not true, because I’m using an export option called “+ Master/Groups/Sends (CSPM)” which does include main out.

You’re right, i forgot about that setting in the screenshot of yours!

@Billy - was this project started in Cubase 11.x? Or perhaps the template was inherited from an earlier version of Cubase?

Cubase 12 handles exports differently than earlier versions but in my testing it only seems to work if the project was created in Cubase 12. I tested exporting groups in Cubase 12 and in my tests they do pick up the sends even if not directly routed the main out. When I tried this on an earlier template created in Cubase 11 it didn’t work.

I reproduced it with a C12 project.

Wait, i just checked something, and at least here in my setup, if I solo a group channel, the FX channels of those tracks feeding the group channel don’t get solo-ed and are not in the signal path:

That actually is something that irritated me (just never needed to export stems so I didn’t notice there), and thus my change in workflow to route FX tracks all to the groups where they belong.

So that would actually make the export behaviour consistent both in the mixer and in the export, although maybe not what one expects…

@fese that happens because you don’t have solo defeat enabled on your FX channels, which you do by doing Alt-click on S.

@Martin.Jirsak could you please read this thread and forward this to development team? It’s quite clearly a bug, because everything works if sends are routed to main Stereo Out, but if stems are routed to sends group (even with solo defeat), it doesn’t work. I should mention again, I’m talking about CSPM export, so it should print out even parallel connections, not just serial ones.

1 Like