Cubase 12 Cannot find my headset (even though it sort of can?)

Hello! I’m brand new to Cubase (coming from DP and Protools) and have been trying to get my equipment all squared away in the program. I’ve run into a significant problem with the Output settings though. I have a headset (headphones with an attachable microphone) I just use for casual purposes (gaming, watching videos, etc.) that I use when mixing to get a general idea what an average listener’s headphone mix would sound like. Now here’s the problem: I am completely baffled on how to get Cubase to play audio out of the headphones.

First, here’s the computer details:
I use an ASUS Gaming Laptop (because its got great hardware) with an Intel i7 core, 16GB of RAM, and a 1TB SSD. Running on Windows 10, with the headset plugged into the built in audio jack. As of right now I have not hooked up any other gear into Cubase (no MIDI controllers, other microphones, etc.). All files for Cubase and its sub-programs are stored on the C: drive of the computer as well.

I’ve so far tried to follow the advice of several topics from previous Cubase versions, all to no avail. Thus far I’ve ensured my audio drivers are all up to date and triple checked that all my devices are enabled properly and functioning as they should be. The computer clearly realizes there is a pair of headphones and an associated microphone AND a separate set of computer speakers both available as sound devices. I even get sound through the headphones when playing audio from another program or Youtube. When I get into Cubase however, I just cannot seem to get the program to recognize the pair of headphones.

Within the Studio Setup window, I have two possible options for my Audio System: Generic Low latency ASIO (which I believe to be my laptop’s built in speakers/sound card, as that is what plays audio when this is enabled) and the Realtek ASIO (which is the actual audio driver stuff for both my headphones and the one my computer typically uses to route sound, even without headphones plugged in). When I select the Realtek ASIO though, Cubase throws a fit and says I need to connect the program to an output. It cannot recognize a single active port anywhere.

If I then return to the Generic ASIO, it recognizes only one option for input and one for output. The output is the built in laptop speakers, BUT THE INPUT is the microphone input from the headset I’m wearing! (The built in microphone is garbage and I’ve physically disabled it in the computer’s device settings). I’ve even tested recording audio tracks to confirm that it is in fact recording from the headset microphone. I’ve spent about two hours now trying to understand how the system is recognizing the microphone from the headset, but cannot seem to recognize the headphones portion. Does anyone know of a fix and/or what even is causing this issue?

Try installing FL Studio ASIO driver and using that, it seems a little more flexible. It’s included as an option when you install FL Studio. I’m using it to get my Bluetooth headphones working :slight_smile:

I believe that would require me to purchase FL Studio wouldn’t it? I don’t think a viable solution should require me to purchase a second DAW…

From a quick look on the web, it looks like the Realtek asio driver is a problem child. You’d probably find more relevant info that way. My personal recommendation though, would be to invest in a dedicated audio/midi interface. Way more functional and less problem too.

No you only need to purchase FL Studio if you want to use FL Studio, you can download and install it from their website for free.

I’ll take a look and see if there are some interfaces that would fit my needs! Its unfortunate that my ASIO seems to be problematic, so I appreciate the suggestions!

Update on this issue: I actually tested two more ASIO drivers and neither worked. I reinstalled the latest Realtek driver to be sure it was not the problem, and no dice. I then also tested the ASIO4All driver and it cannot register the fact I have a headset plugged in either (but ONLY when I’m in Cubase).

I’m starting to wonder if Cubase is compatible with my headset, and if there’s any way to check that?

One more update. I’ve also gone and borrowed multiple sets of headphones to test whether it was just an incompatibility. I’ve used two sets of bluetooth headphones connected to the computer bluetooth (both worked just fine for all audio needs, until I opened Cubase), and another pair of wired headphones specifically for studio use (again, worked just fine for everything until I got into Cubase). When I get inside Cubase, suddenly the mapping of outputs becomes nearly incomprehensible. I can see each set of headphones listed under possible outputs within the ASIO4All driver (very handy), and yet selecting any of them STILL does not render an output signal. I’m genuinely at my wits end.

To be a little more precise, I’ll use my TOZO bluetooth headphones as an example. I connect them to my computer via bluetooth. I then test them using a media player song and a Youtube video. If both work fine, I then launch Cubase. I load up a simple MP3 track into an audio lane, and go into my I/O settings (both the Audio Connections and the Studio Setup). I select the driver I need (ASIO4All), and then go to the possible inputs and outputs. Nothing is visible, there are no options available to me except “Not Connected.” I can go into the Control Panel for ASIO4All and see every pair of headphones connected to the computer available for me to select, including my TOZO headphones as a stereo pair of headphones and a microphone input. I double and triple check the device I’m using is enabled and selected, and at the proper bit rate for the project. I return to the Studio Setup window and still have no options for connections. I physically cannot comprehend why if every single audio device I possess is discoverable, functional, and properly hooked up, why I cannot get Cubase to recognize it is there and output audio to it!? I’m genuinely about to refund the entire program and go with somebody else, because I’ve easily lost over 20 hours to this one issue I could have been tracking music to.

Thank you. I’m having the same trouble as OP and this worked for me.

I have something you can try, Ive been having the same issue and this worked for me.
Open Studio setup - then on the left side beneath “Audio System” select “Generic Audio ASIO Driver”.
On your right you should see the option to open “Control Panel”. There you can go within the driver and choose the source for output. Under “Device Name” I selected my headphone output that was listed below my laptop speakers.

Hope this helps!

+1 to this problem. Can’t get my headphones to work with Cubase 12 from my laptop headphone output. New laptop. No other SW installed. Only Cubase. Tried all sorts of the above. Phones work on startup with YouTube etc, but open Cubase and try to work with headphones. No joy. It seems ridiculous that a high end DAW has users running around in circles like this for something so basic. Not a happy Cubase user right now. Can’t make music if you can’t listen to it!

I haven’t spent 20h chasing this like the OP but I really feel for him. Wasted a good few hours myself so far.

I don’t wish to speak too soon but I might have cracked it.

Following the advice of Bonah Joggs above, which I had tried, I then went to Studio, Audio Connections (F4) and had to select my Outputs, Stereo Out, Left and Right, to Headphones.

In summary:

  1. Studio - Studio Setup, Under Audio System; Generic ASIO Driver, Control Panel, under Output Ports, Device Name, check the box next to Headphones, so that it has an x in it. Click OK…

  2. Studio - Audio Connections, Outputs tab, Stereo Out, Device Port, select your headphones.

Worked for me. I hope it works for you.

Of note, if I unplug my headphones and plug them in again they don’t work. Neither do my speakers! Reselecting my phones under step 1) brings my phones back.

To go back to using the speakers, following steps 1) and 2) and selecting speakers does it.

(I will be using an audio interface, which should alleviate this headache, but I also want the option of working remotely without one at times - the main point in buying a laptop!)

1 Like

Asio4all is made for these issues. It’s definitely the best asio driver for audio production and midi editing software. You have to make sure the settings are good…keep tweaking settings until you get the right combo for your machine . The built in audio drivers are trash and like I said …asio4all was designed specifically for low latency audio recording and editing…keep at it brother!!

1 Like

Hi Mike, I’ve tried ASIO4ALL plenty. The headaches I encountered with that were frequent. I did get a really good setup going at one point, and I thought it was the dog’s b.ll.cks, and enjoyed it while it lasted, but it kept randomly causing hassles, I suspect after automatic Windows updates, so I adjusted my way of working to stick with the Yamaha Steinberg driver that came with my Steinberg UR audio interface. Whilst I don’t have as fancy a setup now (selecting my hardware synths as VSTi’s with a click of the mouse), at least its more reliable and I can stay with the main purpose - making music.

1 Like

Was fighting with the same issues, and this worked for me! Thank you!!!

EDIT TO ADD: I unplugged my headphones and plugged in again to test, and I did have to repeat the ‘Studio’ > ‘Studio Setup’ > ‘Generic Low…Driver’ (left column option) > ‘Control Panel’ > X next to ‘Headphones’ > click ‘OK’ (x2) part again, but at least it’s working!!

1 Like

Interesting problem. Makes me wonder about DAWs, why they haven’t evolved to be more plug&play like multitrackers. Developers should spend more time improving the interface and connectivity and less on the bells and whistles. Cubase has incredible capabilities, but these kinds of glitches waste huge amounts of time and seriously detract from the creative process.

Update: I have a quite different solution, I followed those steps, but when I entered the Audio System in the Audio Setup section in the Studio section (lol) I selected the option: “Reset all devices”, next to a garbage bin icon, and after I did that my headphones device appeared after I tried everything with no success, hope that works for a person other than me!

1 Like

Followed you tip with the Fl asio and it fucked up cubase :smiling_face_with_tear:
i try to open it and it closes down before finishing the splash screen. Then after trying again it brongs me to a menu where you can choose to open cubase with “disabled preferences” and it loads fine :tired_face:

I un installed the Flasio thing and the problem still accures :man_shrugging:t2:

Any ideas?

Hello, not sure if this issue has been resolved or not, but I think I figured it out. If you go to studio setup, audio system, then you’re driver, control panel, then at the top there is a box checked that says allow cubase to overtake audio inputs and outputs, uncheck that and then you should see you’re headset pop up under outputs. This worked for me and I can now use discord and the internet along with cubase.