Cubase 12 Control Room Lovely Graphics Glitch

See picture!!!

on my systems it looks worse, just change the tab and go back again. it is a bug, already known and in each version of Cubase it seems to be different. Steinberg doesn’t comment on it (or I haven’t seen it, and I see the forum every day and several times) so we have to live with it…

1 Like

Would help with troubleshooting if you gave some system info. What version and level of Cubase, OS and version, CPU, graphics card, etc.
Have you updated your graphics card drivers?
Did you try toggling (checking or unchecking) the “Use HDPI” check box in Preferences?

You’re right but I’m just here to show that it is broken. We used to have systems stats in our signature for this very reason.