Cubase 12 Crash on remove track

Hello there, when I try to remove a track sometime on Mac 12.2.1 (Apple M1 Pro) it crash.

Here the crash log

I’m having exactly the same issue. I’m on a Mac Pro with big Sur.
When I duplicate a track, a can’t delete it afterwards.
I’ve tried this with many different plugins.
Cubase simply crashes and exits.

Same problem.
Deactivating track sometimes also ends up with Cubase 12 crashing

I am running Cubase 12 Pro on Windows 10 Pro (21H2). Every time I disable a track (one or more at a time) I get a system crash message. Cubase does not exit, however the message indicates the system is unstable and that I should save the project.

Just upgraded from 11 pro to 12 pro today. Most recent version 12.04.
I have the same issue. If i disable a track i get the unstable system warning. The track disables and can be re-enabled without cubase exiting.
Tried on Halion SE and an arturia instrument and same behaviour.
Same project opened in 11.041 does not give warning message.

Windows 10 home, 21h2