Cubase 12 - Metronome click artifact heard in recording and track monitor - HELP

I have just upgraded from Cubase 11 Pro to Cubase 12 Pro and the metronome click seems to play 2 sounds
One being the actual click, and the other being a quieter artifact

This sound is always present, so long as the metronome is turned on. If I go into my metronome setup and uncheck ‘‘Use Audio Click’’, the sound is STILL in the background.
When I’m in my mixconsole, I can see the click in my active Input channels. If i turn on any instrument channel monitor the click will run through whatever chains of plugins I am using and will print into the audio when i record.
It’s almost as if the click is coming from the instrument itself and not the software, but this was NEVER a problem with Cubase 11
and this glitch is basically making the entire software useless as I can’t record a thing to a click track anymore.

Anyone else having the same problem or have any suggestions???

Could it be that the midi click gets routed through a loopback to your audio input?

I had ‘use midi sound’ ticked as well,