Cubase 12 Pro & ASIO4ALL - No Sound Output after Windows 11 Update

Hello all –

Sorry if this has been covered before, but I’m running into an issue where I am unable to hear the Master Output sound in my Cubase projects.

Here are my most basic system specs:
Windows 11 Professional
Intel i7-13700K 3.40 Gz (not Overclocked)

This is a PC that I’ve built myself earlier this year, and has worked flawlessly for the past several months with my installation of Cubase 12. I have an MBox2 as my audio interface, and have used the ASIO4ALL driver since the beginning, with no issues whatsoever.

Unfortunately, since a Windows 11 update which was performed 2 days ago, I no longer can hear the Master Output within Cubase. I use my MBox2 as my regular audio output even outside of Cubase, and it works perfectly fine for all situations OTHER than Cubase output, even after the update 2 days ago. It is only the Cubase output which no longer is audible.

Here are my configurations, for reference:

These settings are, to the best of my knowledge, exactly the same as they were prior to the Windows 11 update, and again worked perfectly fine. In fact, I can clearly see the signal getting TO the Master Output in my project routing, but I just can’t hear it:

You can see the signal starting in the Instrument track, going through the first Buss then onto a section Buss, then a 2-Buss, then the Master Out. This particular example is a screenshot of my holding down a note with that specific instrument. I see the same behavior in older mixes I’ve created and released prior to the update, and I can’t hear them either, even though the signal clearly indicates it should be audible.

If anyone might take a look at my settings, and suggest if I’ve missed anything, I’d greatly appreciate it. At this point, I’m at a loss on how to proceed.

So, some additional information:

As seen in the screenshots above, I’ve been using the ASIO4ALL driver, the final 2.15 version. It seems that driver has been broken in some way by the latest Windows 11 update.

As I said, I use the MBox2 from digidesign as my interface, but even switching to the device-specific driver still required me to enable monitoring for the instrument channels to be able the hear them, whether it was a new channel that I was playing through, or a channel that had MIDI data already recorded on it. However, monitoring being on ALSO sounded the keyboard input even on channels that I’m not recording on.

I tried switching to the Generic Low-latency ASIO driver, and that seems to have corrected the problem. I don’t need to enable monitoring on any channel, but I now can hear the signal coming through the Master Out.

What this tells me is that it appears to be time to upgrade my interface to something that’s more modern. But, hopefully this will continue to work for now.


I’m not Windows user, but… Have you tried to increase the Buffer Size? 32 samples seams to be quite small to me.

Great question!

I did try that, actually - but there was no difference in performance until I switched drivers completely. In further research about that, the number of samples generally is something that one uses to compensate for a poorly-performing computer, and this rig is custom-built by me specifically for the purpose of making the kind of music I make, and is less than 9 months old. Add that to the fact that everything has been working flawlessly until the Windows 11 update earlier this week, and I’m confident computer performance is not the problem.

I had been using the ASIO4ALL driver in the first place because the digidesign driver that came with the MBox2 has long stopped working appropriately (see my reply above about having to “monitor” all the tracks to get any sound out). So, the update must have broken something in that ASIO4ALL driver (at least for MY usage), and that means it’s time for a better interface. I’ve been putting it off for years, and it’s time. I’ll probably go with a Scarlett because I really don’t need more than that for my usage.

Thank you for the suggestion, though!


Have you seen this YouTube video?
Folk’s are saying it works.