Cubase 12 Pro MIDI recording - sometimes it works and other times it doesn't

This is baffling. I have been using Cubase since the 1990s and have not had this before.

I am on the latest release of Cubase 12 Pro running on a PC with Windows 10. My system seems to be set up correctly. I have a Steinberg UR44 interface and a Native Instruments midi keyboard. All these devices are installed and working perfectly.

If I select say Kontakt 5 and select an instrument I have the input on the track set to my keyboard and the output to Kontakt and the midi channels set to any. I can play the instrument via my keyboard and hear what I’m playing.

Suppose I arm the track to record (record enable button) and press the record button on the transport which goes red. In that case, I get the usual count in and then off we go, except that sometimes it works, and I record midi without a problem, and sometimes the record light on the transport goes out within two seconds and nothing gets recorded.

This is hit and miss. Has anyone else had this problem?


This is seriously odd. If I press record on the transport and it drops out after one second I have found that I can record by simply pressing the record button again on the transport. It starts from the beginning of the track without a count in but it records every time.

Perhaps you have enabled Punch-In/Out?

No idea if it’s related, but when I moved to Cubase 12, disabling the newer WinRT MIDI cleared up some issues for me (Studio Setup, MIDI Port Setup…untick it). I’ve also noticed that some stuff with MIDI drivers has ‘new names’ now since the Cubase 12 update.

I’m using some older stuff, and don’t need the newer WinRT at this time. Not sure what it does anyway? Something to do with Bluetooth and Wireless protocols?

1 Like

Thanks. I have a fiddle around with the MIDI setup and it now works.

Did you sort out the underlying cause, or did the symptoms just go away?

I sorted it out thanks.

When you have got a solution to a question you’ve made, then you should describe the solution so other readers of the post can get the solution too. We’re not reading this for fun but out of interest!

1 Like

OK - fair point. I think my solution could be unique to me.

I have a lot of midi inputs including a Steinberg audio interface, two Roland Guitar Synths, a Roland Guitar Midi controller, NI Komplete keyboard, M-Audio keyboard, NI Maschine, Boss drum machine and a few other bits and pieces.

I went into Studio>Studio setup>MIDI port setup and I unticked Device ‘WinRT MIDI’ (as per Brian’s comment). I then disconnected all my devices and reconnected the ones I was using for the project and hey presto everything worked.

It is this advice you followed then?
WinRT MIDI and Windows Bluetooth MIDI support in Cubase 12 – Steinberg Support