Cubase 12 Pro not using all resources

Hi Guys,

I have a Ryzen 5950x and 128gb of ram, but Cubase 12 Pro doesn’t seem to be using all of the CPU cores and threads, The CPU is at 50% and the Cubase Performance Monitor is pinned all the way.
What could it be? Is there a config issue? Is Steinberg working on a fix? What is the meaning of life?


Hi , system spec would be very helpful here , but first glance are you running on 32/64 in your Audio ASIO buffers ?

Not really sure of any Ryzen 5950x that is not 64bit and Windows… but I’m pretty sure you can tell from the task manager.
ASIO Buffer off, (but also tested ON)but I would love (to hear an explanation as to how this helps?

Ohhh well , it’s you with the problem but if you would like to stay vague about your setup then that’s your right i suppose ,How do you mean your tried with the Asio on and off ?

There is more to real time audio than CPU power. (This has been discussed ad nauseam on this forum and all over the internet.)

Do you feel like you’re not getting the performance you’d expect?
What’s your audio interface? What size sample buffer is it set to and to what sample rate?

Not really sure what I’m meant to do with this information. Does it mean I should change the buffer and everything else to suit my processing power? Is there anything I can do about it? I mean, I raised this with CS and it’s been over 9 days and not a single post on the dang thing.
Anyways, I usually run on 96khz and 1024 samples but this one was 48kh and 512 samples, which are both circa 50ms latency, I tried higher but was unplayable

It’s not necessarily vague if it goes without saying. I mean. I tried with both asio guard on and asio guard off to see if it helps and the result is the same

If you are experiencing dropouts then raising the buffer can be one solution.
It is common that you would increase the buffer when you start mixing a project and all tracking/recording is completed.

If you disregard the performance meter in Cubase, what is the actual issue?
If you are getting poor performance, such as audio dropouts without very many plugins activated, then perhaps your computer is not fully optimized for DAW use. Or, it could simply mean that you reached the limit of your system. Hard to say without further info.

Perhaps stating what type of project are you running (Plugin-heavy, or cpu-hungry vstis…), why the need for 96kHz, perhaps trying with browser closed, no internet?
Also the size of asio guard buffer, as you have 3 to choose from according with chosen asio realtime buffer size? What Focusrite interface are you running?
Are you recording audio or just vstis? You do state 50ms is unplayable, but that could be audio monitored through DAW, or realtime vsti control, we don’t know.

I see, didn’t knew that.

Major audio dropouts, have to freeze tracks and mute others to be able to hear stuff.

Mate, how can a computer be any more optimized for DAW use than to have more resources than the program can handle? CPUs work in fairly simple ways, you have 1s and 0s being pushed out and the thing is being processed translated into other stuff. Like it isn’t that complicated if you’re not engineering the thing.

Both Plugin and VST Heavy, hence why I bought a 5950x and 128gb of RAM ¬¬

All settings were tested, nothing worked made it actually better.
Focusrite 18i20

You literally said the same thing twice… Do you mean hardware latency, plugin latency or daw latency report? Either way I meant DAW Roundtrip Latency (you know, the one in Studio Setup or whatever it’s called).
Eitherway, the MS in latency is not that important, my point was I can not go over these buffer sizes because it just makes for the whole thing unfeasible.

Eitherway, the app is not using everything a machine has, how does anyone else manages to work in big enough projects is mind boggling.

A chain is only as strong as its weakest link. You seem very focused on CPU and RAM, my guess is that there is a bottleneck somewhere else.
Did you build the computer yourself? Have you tried running LatencyMon? What DAW specific optimizations have you performed on the machine? Are all your drivers updated? Is the system “clean” of any unnecessary apps or bloatware? What BIOS settings have you tried changing?
I could go on and on… You may get some really useful help on these forums, but you have to provide the information.

I often run projects with 100+ tracks and the specs of my machine is well below yours. But my machine runs smooth and I only use it for audio.
When tracking/recording I typically set my buffer to either 128 or 64 samples. In this stage, I have hardly any VSTfx activated (they’re turned off, not bypassed) and most importantly, nothing on the busses or main.
When everything is recorded and mixing starts, I bump up the buffer to 1024 to allow for a greater number of insert effects when real time audio is not a priority.

I also have a 5950x with 128gb of ram
And everything works fine for me.

how many tracks are you talking about?

Is Windows optimized for Cubase?

Cubase optimization

Are you only talking about audio tracks
instrument tracks or both
are there many effect plugins

About 30-40 tracks. I think.
But my projects can go sometimes well into the 100s

Are you telling me you’re able to put your system through all of it’s resources while using Cubase?
Can you try it please? Just create a couple of tracks with 3 plugins each and keep multiplying to see where it caps out when you playback with VSTs and MIDI data. If you have a Fabfilter plugins then use the higher latency stuff as well like Saturn HQ Mode and FabFilter Natural Phase, I’m going to try that and see where it caps out so I can get a more controlled environment

You should also know that some plugins can be very resource intensive and / or poorly optimized
If I take for my case the example of the Space reverb from Easwest 1st version
if I add multiple FX tracks with this reverb
Cubase’s resource monitor goes up pretty fast but that doesn’t happen with Cubase’s reverbs
After I think that all VST3 Plugins should work much better in Cubase
A very good way to test your configuration is the Scan Pro Audio test
You download the session then you gradually increase the tracks.
You can test at different buffers
For comparison with my optimized configuration under Windows 10 or Windows 11
I arrive at 121 tracks

Cubase Test 5950x

The link to download the CPR file

Test File CPR

Scan Pro Audio Daw Benchmarks

This is the best way to know if your configuration is optimized
and that there is no bottleneck

There’s another test project created by Dom Sigalis.
There’s a link to that project in this post:

It’s not the same? :thinking: