Cubase 12 Pro upgrade, popping (100dBFS) issue caused by 'ASIO-GUARD' turned on!

I don’t know what to say,
but I have successfully found out that, the main cause of my clicking popping noise problem when I use it along with my hardware synth editor plugin, was:
ASIO-GUARD latency…

Is this a bug on Cubase Pro 12?

Never had this issue! but this, pinching ti ti ti tickly high resonating pop is killing me haha…
Um, what would be the fix for this…?!

Had no issue with my CPU… very light, but every time I tried to record onto stereo track,
I hear this noise from VSTi instrument track…

Luckily if I disable the ASIO GUARD, I get zero popping…

Anyone knows why… and any fix for it?

Thanks in advance!

Just updated to the latest, 12.0.40 Cubase Pro.
I still get popping pinching drop-outs.
I just found out that this is ongoing issue with Cubase 12 Pro.
Um, what would be my best alternative solution…?

Dropouts occur on VST instrument track.

You forgot to mention that you’re using the Prophet’08 Editor.

Please use the VST Plug-In Manager to disable ASIO-Guard only for the affected plug-in. Re-enable it globally by opening the Studio Setup window.

ASIO-Guard shouldn’t be enabled for plug-ins that connect to external effects and instruments


ah… thank you so much Romantique… I’ve been testing myself to narrow down the problem on my mac… but somehow, I never had this issue with Cubase 11 nor 10 Pro…

Would you know why…?

But I guess, even though my mac gets heated a bit, I can just record it straight then disable the Prophet08editor plugin…

But I cannot say, it is the plugin’s problem because I never had this issue on previous cubase pros.
So, that is why I am confused… Thanks though!

Hi JohnShin,

I’ve had this issue too, really frustrating, and i’ve disabled record arm but it still arms when I double click a midi event.

I decided to start using ‘edit in place’ to avoid this issue, but noticed it’s not visible in track settings. I’ve activated it, and now record arm is no longer enabling when I click in midi events so at least I can work without interruptions.

The problem still exists unfortunately, but I can avoid the clicks and pops for the time being.

Might be helpful for you, might not, but I thought i’d share.

1 Like

aha! ‘edit-in-place’ is a great handy feature :slight_smile: thanks! I will try that too :slight_smile: