Cubase 12 random CPU spikes/peaks, interrupted audio?


Can someone from Steinberg please comment on this? I’m on an iMacPro 10 core, 64gb, latest Big Sur, with an aggregate device. At idle with one track, I’ll eventually (within a few minutes) get a random CPU spike that pegs the red indicator. If I add more VSTs, it happens a lot more frequently.

I’ve yet to be able to export even the simplest thing because export is terminated automatically upon a detected spike.

Asio guard setting doesn’t make a notable difference, buffer set to 512, priority is boosted.

Something happened in my upgrade because trying to run C11 pro now throws an eLicenser error. This is a separate issue, but I mention it because I am now dead in the water.

1 Like

I’m happy to report that I got my copy of Cubase Pro 11 working!

Which allows me to say the CPU spikes are definitely a C12 issue.

I opened an empty project in C12. Added one track with Padshop 2 + a ModMachine plugin. Crazy, random CPU spikes all over the place.

Did the same thing in C11. No problems whatsoever.

All settings (ASIO Guard, boost, buffer, audio interface, etc.) are the absolute same.

Any suggestions greatly appreciated.

I’m having a very similar issue with Cubase 12. Windows 10 and spikes and distortion on vst instruments when record enabled or recording but playback seems ok if record enable is off. Same settings and works perfect on Cubase 11. So weird….

1 Like

OK. One other test that points to C12 having an issue.

Created very simple 1 track project.

  • Added a VST instrument.
  • Added an effect.
  • CPU spikes all over the place.
  • Saved the project.
  • Opened the exact same file in Nuendo 11.0.41
  • File played with NO hiccups, spikes, etc.

In Nuendo: ASIO Guard is normal, audio priority is normal, disk preload is 2 secs, 32 bit float processing, 512 buffer.

Same here. CPU is spiking for no reason. Running windows 10, i7 3.8Ghz 32Gb Ram…. ASIO GUARD ON NORMAL,

Much fuller discussion thread here: Cubase 12 Upgrade ASIO-Guard Issue - #41 by bloodline1

Same here, I opened a session and without doing anything there are massive spikes, I have reported similar before but this is a fuller session and the spikes are crazy, switching to CB11 and everything is fine again. There is something seriously wrong with CB12 (Windows 11, 64G DDR5 i9 12900k)

1 Like

You have to to turn off C-state and speed step in bios for stable ASIO with 12900k and C12. Also not forget to set asio guard to high and steinberg power sheme ckeced. There is something with C12 but with all optimisations it works OK for me on W11. We all know update with solution comes soon.

1 Like

I see but it is strange how the 12900k is fine in CB11, for now I have gone back to CB11 until or if they fix CB12

I disabled C-STATE but left the speed step on and I can confirm the spikes have calmed down, thank you :slight_smile:

I know electricity prices went up (in Slovenia 300%) but if you want to work without spikes what we all want we need to optimise. I have all my Power cores fixed to 4900mhz and eff cores to 3700. When I open HW monitor core frequency stays the same all the time. If it jumps cpu asio has up and downs. So I turned off hypertrading too, it brings maybe some additional peace to your DAW, but only little, Im not so 100% but have a good feeling. Try also speed step, or test first with HW monitor like you set it now if cpu seets already now on same freq.

My status:
Running Cubase 12 Pro. The 12.0.20 update did nothing for me :frowning: Having overload spikes, even when at rest, with any combination of VSTs. When I turn off Asio Guard, I still get dropouts. Only difference with it off is that the performance meter doesn’t light up red, despite being audibly dropping.

Latencymon all green, no issues even after running for over 60 minutes. I even bought an AMD GPU to replace my nVidia GPU since Latencymon was showing high issues with their drivers.
I have disabled C-State, Simultaneous Multi-threading (SMT), implemented MSI fix for DPC HDAud.sys Latencymon spike, turned on Steinberg Audio Power. I have erased and installed Windows / the system more than once. No improvement.

My system:
CPU: AMD 5900x
RAM: 64GB Viper 3600Mhz
Motherboard: Vision D-P Gigabyte motherboard
GPU: AMD RX 6600-XT Gigabyte Eagle
Interface: PreSonus 26x32 Quantum Thunderbolt
SSD programs = 970 Evo
SSD sample libraries = 970 Evo & Gigabyte Auros

Suggestions welcome. I couldn’t post this on the bigger thread as it’s been closed soon after the 20.0.20 update (perhaps an idea could have been to wait a bit longer before closing it, to see how well the update performs for users)?

It’s the same for me !
The problem seems to be with new projects created on C12 but it’s the same now with cubase 11 or C10.5
This is a new problem since I have installed C12.


Since I installed C12, I have a big performance problem that makes it difficult or impossible to use the software, but also C11 and C10.5 which are still installed.

When I create a midi track connected to a plug-in, the peak on the project is between 50 and 100% now, which was not the case before. It does it on new projects as well as old ones.

The old projects work with many plug-ins (29 on one of the projects) and very often remain below 25% of peak, or even 5% with 29 plug-ins! (or maximum on C11) if I don’t add a new plug-in.

But if I add a plug-in or change one of the plug-ins of one of the , the peak, even if the project is not playing, rises considerably, beyond 50%, against less than 5% before and reaches 100% in reading, against therefore less than 25% before, or even 5%. It also does this on C11 and C10.5 now. The peak fluctuates between 25 and 50% when stopped.

Finally, if a track that is not connected, or connected to a plug-in formerly assigned, is selected (or connected to a plug-in that is switched off) the peak becomes very low again: a few %.

So it’s dramatic because I can’t create anything anymore.

What to do ?

same problems here with peak overload and interrupted audio. I wonder if they work on it or not enough users have this problem…Nuendo 12.0.51 on Win10

I have the same problem with Cuase 12.0.51 and Nuendo 12.0.51. I hope that this bug will be fixed soon. Cubase 11 works fine. I am seriously thinking about changing my DAW.

1 Like

Same spike problems here. I am not gonna give a report of what i have tried to fix this, but nothing helps. C11 worked fine. But isn’t it shocking that this problem is known since at least the start of this thread and Steinberg did not comment nor solve it…?! (Just answered their survey on their support, but reading this thread I realise I have been much to positive in my answers.)

It’s sad that this is still an issue. On both my high-end Windows desktop and MacBook. And yes, I’ve tried everything, BIOS/OS settings, different audio interfaces, reinstalling OS, using different SSDs, different plugin combinations, drivers, GPUs, CPUs, not updating OS, updating OS, contacting manufacturers of audio interfaces and plugins, contacting Steinberg (the least help unfortunately), arming/not arming tracks, ideas from other users from various forums, talking to users irl, it’s wasting my time and I’m considering other DAWs now.

Have you tried sound card with different io technology? (USB/Firewire/Thunderbolt/PCIe)

1 Like

Yes, I tried with USB PreSonus Audiobox iTwo. Both the Thunderbolt and the Audiobox make no difference. However, these are both PreSonus. I wonder if a different manufacturer might be different. Last week my Audiobox died and I now have an Apogee Duet 3 (can be connected with USB-C or older USB) so will try today.
I tried with an ESI PCIe card and had various issues, including this. But because of issues with the card, returned it. What are you using?