Cubase 12 Upgrade ASIO-Guard Issue

If the problem seems to occur with 3rd party plugins it would make more sense if people would try with and without these 3rd party plugins. Then add them back to narrow it down.

Hi Chriss,

Thank you so much for joining the discussion! I very much appreciate your attention and dedication toward helping discover the root cause of the issue we are experiencing.

Moving forward, to assist in the further investigation, I hope all users experiencing issues and participating in the discussion will provide the detailed information you have requested.

Here is my detailed information:
– OS platform = Windows 10 Pro
– OS version = 21H2, 19044.1586
– CPU = Intel Xeon CPU E5-2687W v4 @ 3.00GHz 3.00 GHz (2, 12 core processors, )
– Graphic Card = Nvidia Quadro P600
– does C12 always fail ? = Yes

Project Details:
– Sample Rate = 44.1, 24 bit
– Asio Guard Level: Low, Normal = audible dropouts / High = I do not hear the dropouts
– Audio Buffer size = 512

– number of VSTi/ Audio/ Midi tracks
– VSTis in the affected project
Complete list available in C12 Demo project = “C12 Demo project = “Cubase 12 - Pop Demo By Austin Hull.cpr_MIXED””

1 Like

This is a compilation of my experiences.

  • System information:
    – your OS platform: APPLE INTEL
    – your OS version number: MacOS 11.6.4**
    – your CPU model and number of cores: iMac Pro 1,1 3 GHz 10-Core Intel Xeon W
    –NEW: your Graphic Card Model: Radeon Pro Vega 56 8 GB
    – Does C12 always fail ? Or just from time to time?
    • At first the problem rendered C12 unusable. I had random spikes even in empty projects. The frequency of the spikes increased if I loaded instruments like Kontakt, Omnisphere, Halion, etc. C11 projects that ran without issue with these same plugins now have issues. I can’t export mixdowns because the export stops because of CPU overloads. Even at idle with one track and pad shop as the VST, I’d eventually (within a minute) get a random CPU spike that pegs the red indicator. If I add more VSTs, it happens a lot more frequently. PROJECT DETAILS: 48khz/32bit, ASIO at Medium, 512 buffer, audio priority boosted, 4 sec preload
    • I also opened an empty project in C12. Added one track with Padshop 2 + a ModMachine plugin. Crazy, random CPU spikes all over the place. I then did the same thing in C11. No problems whatsoever. All settings (ASIO Guard, boost, buffer, audio interface, etc.) are the same in the two projects. PROJECT DETAILS: 48khz/32bit, ASIO at Medium, 512 buffer, audio priority boosted, 4 sec preload
    • I then created very simple 1 track project. Added a VST instrument. Added an effect. I had CPU spikes all over the place. I saved the project. I opened the exact same file in Nuendo 11.0.41. The file played with NO hiccups, spikes, etc. PROJECT DETAILS: C12-As above. Nuendo - ASIO Guard is normal, audio priority is normal, disk preload is 2 secs, 32 bit float processing, 512 buffer.
    • At one point I just completely shutdown and restarted the machine a couple of times. (I rarely turn my machine off.) When I restarted C12 and opened a previously problematic project (with 6 Kontakt instances, no plugin multi-processing), it worked! I left it playing/looping overnight to see if any CPU spikes would be recorded. The performance meters did not register a single spike overnight. I ran the project with all tracks record enabled. No issues! PROJECT DETAILS: 48/32, ASIO is normal, audio priority is boosted, preload is 2 seconds, 512 buffer.
    • Unfortunately that was short lived. I started a new project in C12. I didn’t get very far before the random spikes started happening again.

** - CURRENT SITUATION: All of the above happened while running Big Sur 11.6.4. However, Apple released a point update to Big Sur. I performed the update. I am now running 11.6.5. The random CPU spikes and related issues are not happening for me anymore, and projects that were formerly spiking are not. .I’ve tried creating simple projects using VSTs like Padshop, Omnisphere, and Kontakt and I have not hit a random spike yet. I have no idea whether or not the OS update is related to the lack of issues, but there you have it. (Note that, I have run across a different problem with Aggregate devices. I posted about that as a separate topic in the forum.)

  • Project Details: Included in the above descriptions.
1 Like

My current project:

  • System information:
    Windows 11 Pro
    21H2 Build 22000.556
    Intel i9 12900k 16 Cores (8P + 8E Cores)
    NVIDIA Geforce GTX 1050 Ti
    Cubase fails always

All projects work fine in C11, no glitches, no stutter, no droupouts whatssoever.

  • Project Details:
    – 44,1
    – Asio Guard Level:
    High
    – Audio Buffer size:
    64 samples
    – number of VSTi/ Audio/ Midi tracks
    7 VSTis (+ 1 external VSTi, Waldorf M)
    26 Audio tracks
    13 FX
    15 Groups
    2 MIDI tracks

– VSTis in the affected project
Repro 5
Blue 3
EZBass
Keyscape
2x Superior 3 (1x as track instrument and 1x as rack instrument)
Plasmonic
Obsession
The offending VSTi is Superior Drummer 3 (the rack instrument)

1 Like

Does this help in SD3?

I had the problem of CPU overload causing major audio glitching when running a single audio track and one VST effect (Helix Native or Amplitube 5) on Win 10 PC, i9 processor. Solution turned out to be simple. Just had to activate the Steinberg Power Scheme in Studio Options. This is set to off by default in the update and the setting does not get picked up from the preferences. Certainly worth checking if you have this problem.

3 Likes

DUDE, you’re a damn genius. IT WORKS FOR ME! No more dropouts!

But seriously?? Activate Steinberg power scheme?? That’s what the whole thing is tied around to?? What’s up with that??

Besides, I’ve already manually disabled all power-saving options in Windows Settings itself. So this quite stumps me.

Anyway, props to ya, thanks so much!

1 Like

It permits your computer to operate at full power.

Lol, I know that. But I’ve already manually disabled all power-saving options (USB, PCIe, etc etc) in Windows Settings itself. Not sure what else the Steinberg power scheme could add to that.

Something you missed? Have you compared the power plans in Control Panel\Hardware and Sound\Power Options\Edit Plan Settings>Change Advanced Power…

Yep, I have. Everything manually disabled. I check after every Windows update as well.

Oh well, I guess Steinberg power scheme has its own ingredients that’s not seen in the Advanced Power Settings in Windows. Either way, I’m glad I can start using C12 now. Won’t delete C11 yet still though, just in case.

What about CPU speed?

1 Like

C-states and Speedstep is turned off in the BIOs.

2 Likes

Big thanks to @Andrew_Norman for figuring out the Steinberg Power Plan as possible difference to your C11 installation! This setting doesn’t get transferred from your Cubase prefs to the new C12 prefs. We should consider to enable the scheme by default, as power saving profiles become dominant. When you close Cubase, the power plan is reverted back to your earlier settings, so no worries about wasting too much energy.
Thanks also to all of you sending in your system and project setups! That was very helpful, too. So far, it looks like only Windows users are affected by the dropout/ overload issue. The only macOS system reported was solved after the update to macOS 11.6.5 (please correct me, if I miss something). There were also no settings/ instruments/ plugins/ graphic cards/ system properties which all of you had in common. This also lets me hope that most of you will be fine when activating the Steinberg Power Scheme.
I hope you can now enjoy C12!

3 Likes

Thanks Chriss for the update.

Unfortunately for me, activating the Steinberg Power Plan has no effect on my issues. I have tried both with the power plan on/off, I still get an audible dropout, when ASIO-Guard is set to Low or Normal. When AG is set to High, I don’t hear the dropouts (they may still be there, but I can’t hear them).

Steinberg power plan has been activated from the beginning. Strong peaks and dropouts (see above)

2 Likes

That is very interesting, in that when i compared Steinberg Power Scheme to my manual changes in Device Manager, they were quite similar.

I wonder why Cubase responded differently …

1 Like

Unfortunately not, as I have SD3 set that way already.

While that is always a good idea, it doesn’t apply in my case. That setting changes Windows power-scheme settings only if you haven’t done that manually already. Since I already set the Windows power-settings when installing Windows, the “Steinberg power scheme” doesn’t do anything on my maschine.

1 Like

Sorry, not over here. It doesn’t matter if the Steinberg Power Scheme is on or off, the problem remains.

BTW: That setting doesn’t make any difference in C11 neither.

That means it’s an Cubase issue, no?

Come on guys, there is certainly something that you have changed from C11 to C12. It shouldn’t be that hard to figure out what it was.

Also keep in mind that switching away from a heavy spiking track to - say - an empty track has a huge delay and unloading/reloading VSTs (according to the CPU meter, but also audible, some effects are just gone for a second and come back).

I think I have mentioned that numerous times in this thread and there is no way that is related to the power scheme. That’s certainly a Cubase issue.

2 Likes

Ok… the power scheme does the trick for some, but by far not all of you.
We’ll dig deeper tomorrow. Will keep you updated. We are working hard on this.
Cheers
Christina

3 Likes