Cubase 12 will not work with Nvidia G-Sync, constant black screens

Hello,
I built a new PC with Windows 11 and recently upgraded to Cubase Artist 12. I can not run Cubase and have G-Sync activated at the same time without getting repeated black screens making work with Cubase impossible.

To reproduce:
Have a PC with an Nvidia Card and Drivers, also a Monitor which is G-Sync compatible (AMD FreeSync Pro will work as well).

  1. Make sure G-Sync is enabled in Nvidia Control Panel
  2. Start Cubase 12
  3. Regardless of what I do in Cubase after a few seconds the screen will go black (just as if someone had disconnected my monitor cable), then come back for a moment (just as if someone had plugged the monitor cable back in), this will repeat until I quit Cubase 12.

Disabling G-Sync will prevent this from happening, adding an exception for Cubase 12 in the Nvidia Control Panel and disabling G-Sync there, setting the refresh rate to a fixed value, will not work. However I would like to enjoy the premium features of my hardware when Cubase runs in the background. I am creating Game Music with Cubase and it is necessary for me to run Cubase as well as a game at the same time.

My hardware and config:
Windows 11 with latest updates
AMD Ryzen 5900x
64GB RAM
Gigabyte RTX Eagle 3080 OC 10GB
MSI mpg x570s Carbon Mainboard
Seagate Firecuda 1TB SSD
Gigabyte Aorus FI32U Monitor
Nvidia Driver 516.94

Weird, as I have it activated but no such problems.

However, what I have noticed is a strange flickering at times - I run a 4k/120hz desktop and for some reason G-Sync seems to sync @ 60hz with Cubase. But then other times it gives me the 120hz fine, so I think there may be something a little odd going on there.

Have you checked your monitor info when running Cubase to see what it’s trying to sync at?

Do you have G-Sync set for full-screen only? Or do you have it for full-screen and windows? - May be worth seeing if that makes any difference as Cubase is a windowed app.

I have set it for full-screen and windowed. I’ll try switching to full-screen only. Everything else is running perfectly at 144hz, the monitor’s maximum. I am a bit surprised that Cubase is having such problems, since no other windowed application has any problems, not even when I am running a game in full screen, either on another screen or with only one connected.

Edit: tried it, switching to full-screen only G-Sync does not change anything. As soon as I start Cubase 12 the screen will turn black periodically. Only disabling it will solve the problem, but I’d prefer Cubase working properly with G-Sync as all the other applications I have.

Soo… do Steinberg usually confirm issues here when they acknowledge them?

Hi,

Sorry, I’m not Windows user, but here is the way, how to install Nvidia to work with Cubase.

Please try this:

  • Download the latest Studio driver version from here. If there is no Studio driver for your graphic card, use the one, which is available and continue with the same steps bellow.
  • Disconnect the computer from the Internet to make sure Windows will not download and install its own graphic driver.
  • Uninstall the NVIDIA driver.
  • Restart computer.
  • Start the NVIDIA driver installation (as administrator).
  • Don’t install the whole package, use the Custom (Advanced) settings.
  • Disable everything (don’t install NVIDIA Experience, PhysX, etc.), keep just the video driver enabled.
  • Connect your computer to the internet.

That’s simply because Cubase runs at 60 fps, but since it is a windowed program, G-Sync still syncs to the desktop refresh rate.

In your case it’s a multiple of 60, that must explain why it sometimes looks smooth, when Cubase refresh rate aligns to the 120 Hz so you briefly have exactly 1 image for 2 refreshes, but since the framerate of Cubase moves around due to performance (like it would in a game) this “smooth” effect won’t last forever.

I talked about this in other topics already, if Cubase was automatically working at the same frame rate than the desktop there would be no issue.


I have the Gaming driver with the whole package installed and I have no issue with Cubase.
PhysX and GeForce Experience play no role in running software, it’s only for games, and the Studio version will only optimize the performance of 3D modeling or video editors software.

1 Like

Hi,

This doesn’t mean, other users cannot have an issues. And I know, this process helped several users already.

I believe, there is a reason, why the developers release the Gaming and the Studio driver.

1 Like

Yeah, the studio drivers are basically a Long Time Support (LTS) version so commercial setups in companies are more manageable. Same drivers, different testing, different release cycles.

And it sadly doesn’t help me with my problem. For one, the situation is exactly the same - I tried them. And on the other hand… since I am creating music for games and need to regularly run the current branch with new music I want to do that with the gaming drivers. And I would still like to not have to disable G-Sync, for various reasons.

I mean I do not have this problem at all with any other productivity software. I have tried it with two other DAWs (one trial version and one that is for free) and the competitors do not cause the problem at all for me. However, I paid quite some money for Cubase and like it best, so I’d really prefer to use Cubase, with the gaming driver and with G-Sync activated. I don’t think this is a wild request. :wink: