Cubase 12[Win] keeps screen on forever

Something about having Cubase open keeps my screens on 100% of the time. I closed my projects before I left for the day, but I guess I didn’t quite succeed at closing the program. I came back 12 hours later and my screens were still on.

I do professional color work as well as mixing. If this happens more than a few times it’s going to ruin thousands of dollars worth of monitors. This is unacceptable.

How can I make this stop happening?

Just make sure you quit Cubase.

I agree this happens to me and it’s annoying. Hopefully they can address this in an update so it respects screen saver settings

Hilarious. Or, hey how about this, how about I purchase a DAW that doesn’t ruin my hardware?

I’ve been caught out by this too. It’s most tricky when Cubase is behind another window. On the other hand - I don’t want a DAW that will suddenly go into some ‘saver’ mode when I’m trying to record something. Do modern monitors get ‘burn in’ still. I’d heard not … but I’m not risking mine!! :slight_smile:

I suppose that’s an option!

I presume that’s why it works like this. So to me, the “solution” is to turn the monitor off, or quit Cubase.

Maybe make this a feature request, if it gains traction an option might be added…

If you are on Windows and use the Steinberg Audio Power Scheme, disable that setting and setup your own power plan. You can find these settings here:
Start > Settings > Power & Sleep > Additional power settings
There you can specify when you want your screen to go to sleep.


EDIT:

:point_up_2: This was an assumption based on how I believe it should work.
According to Steve’s finding below, it does not seem to be the case.
Bug or feature? :person_shrugging:

1 Like

I think Cubase creates activity that stops the power settings from sleeping the display, at least that’s what I saw just now when I set it to turn off displays after one minute.

With Cubase running the display stayed on, with Cubase not running it went off.

A new “feature”?
I must admit, I haven’t let my screens sleep in 15+ years.

Pretty much the same here, I did not even know that Cubase prevents display sleep until seeing posts about it here… Has it always been so? I think yes, at least for a few years.

Yes, Cubase does prevent screens from sleeping.

Are you on Windows or Mac? On Windows, I always keep my Task Manager on, so I can just quit Cubase or Nuendo everytime it doesn’t close properly.

Quite the opposite here!
Working on 4 large screens, it’s out of question for me to leave screens on and waste energy even for 5 minutes when I’m away, not to mention screen burn-in when left on for hours.

FYI this request has been addressed to Steinberg a few years ago by yours truly :blush:
Still hoping for a “fix”, though it was originally supposed to be a feature!

1 Like

I didn’t know LED screens could suffer burn-in, so I took a look over at Wikipedia.
Screen burn-in | Plasma, LCD, and OLED displays

Exerpt from above article

In the case of LCDs, the physics of burn-in are different than plasma and OLED, which develop burn-in from luminance degradation of the light-emitting pixels. For LCDs, burn-in develops in some cases because pixels permanently lose their ability to return to their relaxed state after a continued static use profile. In most typical usage profiles, this image persistence in LCD is only transient.

Both plasma-type and LCD-type displays exhibit a similar phenomenon called transient image persistence, which is similar to screen burn but is not permanent. In the case of plasma-type displays, transient image persistence is caused by charge build-up in the pixel cells (not cumulative luminance degradation as with burn-in), which can be seen sometimes when a bright image that was set against a dark background is replaced by a dark background only; this image retention is usually released once a typical-brightness image is displayed and does not inhibit the display’s typical viewing image quality.

The energy waste is of course a valid concern.

1 Like

That’s actually great news because every time my screens go to sleep, they never wake up properly again and I have to reboot the whole system to get back into a working state. So this is a feature, not a bug, for me :slight_smile:

Yes, panel burn-in is still a thing. Depending on what kind of panel you’re working with, luma consistency and perceived intensity of the backlight across different sections of the screen can drift over time depending on usage. Color accuracy and white balance also drift as the panel ages. It’s for these reasons that it’s standard practice for colorists to have their monitors recalibrated as they age. Sometimes even annually.

I get that most people don’t care if Cubase accidentally deteriorates their hardware. I get that some people may even like that. But other don’t - and for entirely legitimate reasons. Also, it’s an inherently wasteful and stupid practice for which better solutions exist elsewhere.

For example, if you simply MUST have your screens blasting light to a completely empty room while Cubase is open, fine. Use Windows Powertoys “Never Sleep” mode with the “keep screen on” option selected. Now you can deteriorate your hardware to your heart’s content and my expensive color-accurate screens won’t needlessly inch closer to EOL bc Cubase won’t let them rest.

I think making this an optional feature is an entirely reasonable request. I’m curious regarding your panel burn-in comment because it seems to conflict with the information on Wikipedia. Can you please point to the source/data/study that substantiates your claim? I’m especially curious whether it’s correlated to usage, to panel aging regardless of usage, or both…

1 Like