Cubase 12 with Komplete Kontrol S61 on M1 Mac, no sound

I am running Cubase in Rosetta on an M1Max MBP with a Komplete Kontrol MK2 S61 keyboard. Set up is as per the many tutorials found on the web. Midi port setup shows the KK in and out as well as in and out of DAW-1 is active, remote devices in and out are set on KK DAW-1.

All buttons like start, stop and record and also the knobs off the KK work, the browswer works, the light guide works but the actual keys of the keyboard do not produce any sound while playing. They do send midi info to Cubase as I can record by playing on the keyboard without sound and when playing back the instrument sounds correctly.

What setting is missing or wrong ?

Is your Control Room set up properly? Do you have another MIDI input device that does work as expected?

Thanks for the fast response.

I do not use the control room and never touched any settings in it. I have no other midi device.

I did some more testing and think it might have nothing to do with the KK keyboard but with the connection between the way the loaded plugins receive direct midi input, so not from the track and produce sound as output. This is what I tested:
-1- If I use the virtual keyboard shown in some plugins, all works correctly and notes hit on that keyboard with the mouse sound correctly
-2- If I use the Cubase on screen keyboard, I have the same issue as with the KK keyboard; no sound when played but midi is written correctly to the trackā€¦

(Replied to wrong thread)

Thanks mlindeb. I solved it.

After I discovered the virtual keyboard did not work either I suspected it were the general midi processing settings. So I. went to the Cubase preferences and under Midi activated Midi thru. This makes both keyboards work again.

Not sure why it became unticked or if the default is no Midi thru. but activating solves the problem.