Cubase 12 won't start - "Entry Point Not Found" [Windows 10]

I get two messages. One about GetSystemMetricsForDpi and one about GetDpiForWindow. I’ve tried reinstalling a couple of times, run as administrator and so on. Any ideas, guys? So so keen to get into this new version.

I Have the same messages…

Hello , same problem.
I’ve tried several installation , I’ve also done the product activation via Steinberg Activation tools but got always same error.
Any idea ?

Hello,
“Entry Point not Found” message too for me, and cubase 12 won’t start.
Did you check your windows version ? Windows update tell me that my version is up to date, but I suspect that it is an older one (ie before 21H2).

Has anyone managed to resolve the issue?

I updated Windows to21H2 and this solved the problem

Any other solution apart from upgrading to 21H2?
Will updating to 20H2 solve it
How much space and internet data does these updates take?

The minimum requirement for Cubase 12 is 21H2 on Win 10 or 11.

thanks

I got the same Error msg " Entry point not found" no matter how many time I install it. I also tried reinstalling Visual C++ Redistributable Packages for Visual Studio 2013, but did’nt work. Then I read the system requirement that Windows 10 version 21H2 is must for Cubase 12. Eventually I Formatted my Pc to the latest Windows 10 21H2 version then Installed Cubase 12 again and it worked.
So the Solution is : Updrade your windows version to 21H2 .