Cubase 13 KernelBase.dll crash whenever i try to open massive X + wont load some vst's

I have upgraded my cubase 12 to 13 a few days ago, and the first time i opened it everything loaded just fine without any problems.

Yesterday i tried opening a project and all of a sudden some of the vsts were recognized by cubase (as i could have seen them in the plug-in manager) but whenever i loaded them i couldn’t get them to open and in the channel it said “No Vst Instrument”.

Then i tried opening a couple of more plugins like kontakt, augmented strings, sylenth1 ect… Which did load, but then Massive X and regular massive gave me this error message saying The KernelBase.dll has what caused the crash.

so i opened the DUMP file via WinDbg which said:

WARNING: Check Image - Checksum mismatch - Dump: 0x3bcd90, File: 0x3b3aed - C:\ProgramData\Dbg\sym\KERNELBASE.dll\2B72307B3a6000\KERNELBASE.dll

And alot of other stuff, but the main module in the crash DUMP was Massive X.

The thing is, i don’t know if that’s the true problem, since I tried opening it in cubase 12 and get the same error and Can’t load some of the instruments i was able to just a few days ago.
even some presets of mine are now not recognized in some of the plugins that i can open, like vital for example.

So some of the plugins are recognized but won’t show, and some i can open but i get a kernelbase.dll crash right after which forces me to close cubase.
Others run just fine.

It is also worth knowing i have opened MASCHINE 2 and i can load the vsts that wont show or give me a kernelbase.dll crash on that DAW…
AND upon opening cubase 13 it says: “Your document folder is not accessible!
You might not be able to save presets.”
image

Here is what i tried so far:
-Installing latest windows update+Reversing back and forth.
-Ran SFC scan + DISM and more CMD commands
-Tried re-installing Massive X and the plugins that are recognized but wont show nor open.
-Re-installed Cubase 13 and 12 from the download assistant + Control panel+Repair
-Tried to change the kernelbase.dll in another one

Please help me find a solution.
this is important for my work.
Thanks in advance.

Here is the DUMP file.
Cubase 13.0.30 64bit2024.3.30 20.15.35.479.dmp (1.6 MB)

image

Have you tried to run it as administrator? Also do you use virus protection? It may prevent you to access certain files and folders.

1 Like

Thanks for the quick reply

Yes cubase runs as administrator by default for me.
i only have windows security program, don’t have any other.

The issues is a bit more deeper than that it seems…

You could try exclude Steinberg folder and others related in the windows defender. Or/and stop the realtime protection for testing, if it makes difference

Yes i have tried that and it does not seem to make any change…

I just managed to solve it after 3 days of web surfing.
hard to believe after all the steps i took in order to fix it, it was just an on and off button.

What stopped everything from working right was “Controlled Folder Access” in the virus & threat protection by windows.

I am so happy i got over it, hope this can help other ppl too.

1 Like