Cubase 13 - Mackie Control: "insert position marker" not working


When you hover over the command in the API documentation, you can see the original command, you have to use in the script.

1 Like

Thanks for your kind help,
m.c. and Martin.

My mistake was, that I had searched here -I thought everything was up to date under this link:

i can confirm set marker is working in cubase 12 but not in 13. using xtouch one as mackie control. Also if i set a button as shift the combination of shift + f1 f2 etc does not work in any version. Im a newbie to mackie so hope anyone can look into this thks


Which functions have you assigned, please?

setting xtouch one to mackie user mode i can define any button to user defined function at which I use the scrub button, pressing the button in setup mode will show it is assigned to shift, however pressing the combination for shift + f1 behave just like pressing f1
as for setup instruction here’s a memo to myself -
“ press stop button and press encoder

or press encoder while powering up

turn to u for mc user mode

must assign while in led brightness mode not yet exit setup

press any custom button and turn encoder knob to assign custom function f7 f8 for eg”

here’s the mackie setup

The native script for the PreSonus FaderPort works now.
One ( = the same) control element is able to make the function Insert Marker
whether Cubase 12 or Cubase 13 is running.

To realize this, I defined two custom variables in the script:

If you want to see exactly how I solved this, you can go to “shared-midi-remote”, “PreSonus FaderPort 2 (2018) midi remote script”, view the last update “PreSonus_FaderPort.js” and search there for these custom variables.
If Cubase does not recognize a command, it will be ignored without an error message. This means that Cubase 12 ignores the command for Cubase 13 and vice versa.

Here is some understanding for Steinberg on the subject:

Of course I can understand why Steinberg moved the “Insert Marker” command from the “Transport” group to the “Marker” group.

Fortunately, Steinberg has implemented so many new marker functions that it made sense to combine them all under the “Marker” group, because otherwise the “Transport” group would have become too confusing.
If the “Insert Marker” command had been left in the “Transport” group, other programmers would have complained at some point that this command was not in the “Marker” group because they expect that if you define a certain group, all the relevant commands will also be there.

I have the same issue. Impossible to insert a marker with my Mackie Control universal pro in Cubase pro 13 !
It was ok with Cubase pro 12…
Please, Steinberg, resolve this bug !

1 Like


This issue is going to be fixed in the 1st maintenance update.

I have now adjusted to the fact that the commands for ‘Insert Marker’ are different in Cubase 12 and Cubase 13. So Steinberg can leave it as it is now.


I wrote you this short time ago: :wink:

You are not the only one, who is facing this issue, of course.


Cubase 13.0.20 maintenance update, which includes the fix, has been released. Please, download and install the update.