Cubase 13 -- Mouse click in Key Editor background to set vertical cursor position?

You know how you can click in the Project Window background and the vertical cursor snaps to the time under your click (mouse point)?

Is this functionality possible in the Key Editor. Currently, I have to click in the key editor ruler to set the vertical cursor at the measure/beat I want.

It would be great to be able to do this, but I’m thinking it’s not possible.
Anyone else?


I use Alt+Shift+Mouseclick,
I guess Opt+Shift+Mouseclick on Mac.

Thanks, Johnny. When I alt+Shift+Mouseclick in Windows, a note is placed at the click, which I believe is the default behavior (or at least Alt+Mouseclick at any rate). The cursor does jump to the end of that note. but what I mean is to have just the vertical cursor align to that mouse click. Just as it does in the Project Window when you click in the background field.

The reason is I’d like to quickly place the vertical cursor for playback without relying on the bars and beats timeline.

This is definitely not the default behaviour and I would not know any way to get to the behaviour that you describe. Did you by any chance perform the action in haste? Creating a note is done by default with the Alt+Mouseclick, without the Shift key.

For some reason the Alt+Shift+Mouseclick is inserting a note. If I just single mouse click without dragging, the cursor positions itself at the end of the note. If I click and slightly drag the start of the note without releasing, the cursor positions itself at the beginning of the note.

But it’s still inserting a note, regardless.

I’ll try to get a screen capture of the behavior and post back.

Here’s a screen capture.

In the Project Window, I’m left clicking with the mouse. Cursor positions where the click is.

Then, below in the Key Editor:

  1. I’m first left clicking with the mouse and you see no cursor appears.

  2. Then I click in the time ruler and, of course, the cursor appears where the click is.

  3. Then, I Alt+Shift+Click in the background of the Editor and you see the note appears with cursor positioned at its end.

  4. Lastly, I Alt++Shift+Click and slight drag the note before releasing the mouse and you see the cursor appears at the note’s beginng and stays there on mouse release.

Hope that helps makes my explanation clearer.

Alt+sft-click in the Key Editor should not produce any midi note. It should only achieve what you do in step 2 which is the cursor appear where you make the click.

A double click will produce a midi note in the Key Editor.

If you really can create notes by holding down Shift and Alt and then performing a single click with the left mouse button, it might be time to disable the user preferences.

When starting Cubase directly after double-clicking the Cubase icon, hold Ctrl+Alt+Shift… → Disable program preferences

It’s most likely the Tool Modifiers though.

1 Like

I’ll try that. Thanks.

Ah-ha. I’ll definitely look at that when I get back to the studio. Thanks!

Thanks Johhny and Steve; I really appreciate the help.
It did turn out to be the Tool Modifiers. My set cursor position action wasn’t assigned a modifier.

I wish I could just get this behavior by using only a single left mouse click in the background, but I’ll take Alt+Shift+Mouseclick. Works well.