Cubase & 4k Monitor

I have a 27" 4k monitor and I tried using Cubase 8, it won’t scale with any scaling I had with windows, it just stays at 100%. I read the official solution about clicking the “disable High DPI” setting thing but that didn’t do it.

Any help?

Hi there, what version of windows are you using? I’ve been using a 4k monitor on Windows 7, and Cubase doesn’t really scale at all. With some windows settings, you can make some buttons and text bigger, but not much else.

Win10 should scale it, but check your cubase 8 version. there may have been a patch that improves scaling on win10.

4K needs a big screen (minimal 32 inch), otherwise you are just applying temporary quick fixes!
The 27 inch isn’t the right match for this resolution when using text sliders buttons etc etc, it’s only suitable for films & photo’s in this size.