Cubase 5.5.3 & Mavericks Problem

Hi all,

just installed Cubase 5.5.3 on my Mac Book Pro i7 Retina and loaded my first song which is from SX3. It played ok but the playbar wasn’t visible on the page, only at the top of the page.

The main problem is the cursor. It’s working but it seems it’s not clicking where it should be. e.g. if I position the cursor and click in the centre of the page it’s actually clicking down several inches and left a bit. I’ve tried resizing the desktop resolution in display preferences but it still does the same. See C5 Cursor.jpg attachment.


Some of the smaller Save windows and the Top Line File Menus work fine.

I’ve read that a lot of people are using Cubase 5 with Mavericks without any problems but for me this is a nightmare. Anyone got any ideas?

Thanks in advance.

Cubase 5 has been discontinued for several years and is not officially support for 10.9. Personally I would recommend upgrading to 7.5 for use on 10.9.

On C5 with a retina display, I would suggest going to Applications, selecting Cubase and pressing Command-i to open the Get Info. Check the option to “Open in Low Resolution”.

Or if possible (and you really only want to use C5) how about downgrading the OS on yer ax?

Funny tho’ C5.5 opens and seems to works fine here on 10.9 (no retina)
I say ‘seems to’ because i have not done any real work in it for a while.

But it will open and playback previous projects done in that environment
with no probs.

Other than plugs and some FX changes all audio and MIDI tracks work fine.

Good Luck!
{’-’}

Thanks Chris and curteye, my problem was solved in another thread (for AI/LE). I did originally consider dropping back to Mountain Lion but I don’t think my Mac (Late 2013) will let me install it. It came with Mavericks so probably wouldn’t let me install anything before that. I don’t have a copy of it either as I came straight from 10.6.8 on a 2007 iMac. I tried going back to the original install of Mavericks (10.9 or 10.9.1) using online recovery but it downloaded 10.9.4 which I didn’t want. Constant forced updates! I’ve got just about everything working now (taken a few months) so gonna stick with 10.9.2 for a long time. Don’t want to update past this as the update (both 10.9.3 and .4) start giving me graphics problems with another application. At the moment it’s happy days!

Glad you got it sorted.
{’-’}