Cubase 5.5 MIDI Recording very early, happens out of nowhere

Hi guys,
I’ve got a major issue.
I installed a Alesis DM10X Midi kit to trigger Superior Drummer 2.0 in Cubase.
When I open a brand new project, everything records fine and perfectly in time, etc.
All of a sudden out of no where the MIDI drum hits will begin to record early, VERY EARLY.
And I have no idea what’s going on. i’ve tried reinstalling the MIDI drivers, I thought it was a Midi driver conflict or something. I’ve tried for 10 hours now and give up.
When I open a fresh project, everything’s all well for about an hour, and then it happens again.
Here’s the thing, once it starts recording midi early, this applies to EVERYTHING, piano, anything midi, will record early and there’s nothing you can do to fix it unless you start a new project.
Please shed some light as to what I could possibly do, I don’t know what’s going on.
Cubase user for about 4-5 years.
Sincere thanks,
Mark
Issue.jpg

Search Knowledge Base for System Timestamp and Emulated MIDI Ports.

Hi, No luck with that, tried everything that has to do with MIDI ports and time stamp. No luck…any other ideas?

Need to use the Emulated MIDI ports.

By this you mean Directmusic MIDI ports, yes I’ve tried it but no luck.

Buffer does not affect it, it’s a very strange issue. Some kind of conflict between the DM10 module, and USB drivers and Cubase, somewhere in chain but no clue where it’s coming from. I use USB, but have recently stuck a MIDI cable out instead to see if the issue still persistst. I use Win 7, i3770K processor, 32GB ram, pretty beefy computer but the issue is in the software…

Emulated does not = Direct Music.