Cubase 5 - Can't get input transformer to filter MIDI chann

Hello,

What I thought would be an extremely basic function of Cubase has turned out to be quite difficult to achieve.

In my live setup I have a MIDI keyboard. This connects via MIDI to a Roland UM-4 (midi 4-port type thing), which then connectes via USB to the laptop. On it I have Cubase 5. Of course, I want to have more than 1 different sounds for my whole live set, and I can’t close/open other projects through my set either, or mess with the laptop in any way. So how can I switch between sounds?

I thought it would be just a matter of setting the MIDI channel on the keyboard, then having up to 16 MIDI tracks in Cubase, each with own sound and MIDI channel, and then all I’d have to do is just change the MIDI channel on the keyboard itself and hey presto! But no - that would be too easy, wouldn’t it?

When I try the above, I get all 16 MIDI tracks all receiving all the MIDI data at all times? How can this be if I’ve set to a particular channel on the keyboard?

I’ve tried three different keyboards as well, so it’s not the keyboard playing up.

I’ve then looked at (e.g. for MIDI Track 1) setting the ‘Input Transformer’ to ‘Local’ , and the selecting ‘Channel Filtering’ -> Pass CH 01. But this doesn’t stop the other channels’ data from getting through either. Am I doing it wrong?

Any advice you can give on this would be appreciated.

Thanks.

Let me put it this way: If you do it right, it works.

Except it doesn’t always. 6 years later and input transformer is still broken. I have two different projects… IDENTICAL settings for both tracks and input transformer. One works, the other does absolutely nothing.