Cubase 5 crashing when reason is launched as rewire slave

hey there im looking to see if anyone has any insight that can help
i am using some older apps because of my licenses but let me summarize the issue:

im using an older Windows 7 PC (AMD x3 445 cpu) running Windows 7 SP1 –
I’m running Cubase Studio 5 (32bit install) it’s working fine! with my elicenser usb and works great untill i try to launch reason as a slave when it suddenly crashes immediately as reason is starting

reason essentials 8.1 (32bit) is crashing Cubase Studio 5 everytime i launch as a rewire slave
whereas Ableton Live 8.4.2 (32bit) is running fine as a rewire slave to cubase studio 5 (32bit)

i was trying to verify 32bit rewire working between Reason + Cubase, to do Bus Recording of Rewire in Cubase Studio 5 (Which is usually only a cubase PRO feature).

can anyone offer me any ideas on what else i can do to try to fix this error. the reason splash screen appears but does not complete startup before cubase crashes, then reason will also crash and both apps will exit.

i also tried installing reason 6.5.3 as 32bit to try, and it also crashed Cubase in the exact same way, so it is not a problem caused by Reason Essentials v8.1 specifically.

i was thinking that this is something to do with Rewire Crashing because if the reason app starts up normally (non-rewire) with cubase already running, it doesnt crash cubase. so it seems to be related to the rewire engine??

Try using the Windows Event Viewer to figure out which app is crashing and causing problems with certainty. Look under the Windows > System logs. Use the filter to filter out the Information entries and look at the entries at the specific time Cubase crashed.
The info for the entry that’s highlights is in the bottom pane.
I’m using:
Cubase Pro 11.0.20
Win10 x64 1909
Reason 10.4d4
and am able to run without problem, just as a bit of data/comparison. Pretty different from your rig, but worth noting.

i found this under Computer management > Windows Logs > Application

Cubase Studio 5.exe
C:\Program Files (x86)\Steinberg\Cubase Studio 5\Cubase Studio 5.exe

That’s an system file. A quick easy check to make sure Windows is OK is to richt click the Start menu and select Windows Power Shell (Admin) and enter:
sfc /scannow
at the command prompt. It will take a couple minutes to scan.
If it finds any thing, then enter this (you can copy and paste these in)
DISM /Online /Cleanup-image /Restorehealth
That should fix any problems coming from the Windows side.

please note that it works 100% perfectly between Cubase Studio 5 (32) + Ableton Live Lite 8.4.2 (32)
32bit REWire works 100% perfectly between these two apps, for whatever reason it seems to be only the combination of REASON slaved into CUBASE that gives the instant crash result.

whatever is causing the problem, happens when i launch both Reason 6.5.3 (32bit) and Reason Essentials 8.1 (32)bit – both of these will IMMEDIATELY crash Cubase when Reason is launching
but if i was to launch a (64) bit version of Reason it has no affect because it doesnt try to launch in REWIRE slave mode.

must i try to remove the rewire.dll files?
Windows 32-bit: C:\Program Files (x86)\Common Files\Propellerhead Software\ReWire\ReWire.dll
Windows 64-bit: C:\Program Files\Common Files\Propellerhead Software\ReWire\ReWire.dll

Yes but Cubase could be making different calls to the OS. That NTdll.dll is a core OS file that Cubase might be engaging. The Event Viewer suggests that is the case. It’s up to you.
If it was me, I’d definitely do those two scans.

Google it and you’ll find plenty of answers like this
As the error message indicated that the “ntdll.dll” is faulting module, please run the command SFC to check if there is a corruption: Type the following command to an elevated command prompt, and then press ENTER:

sfc /scannow

The sfc /scannow command scans all protected system files and replaces incorrect versions with correct Microsoft versions.

That is it only does something if it finds a corrupted file. This is a Microsoft program (sfc) that’s part of the operating system, so it’s safe to use.

heres what i see visually when trying to launch Reason from inside Cubase Studio 5
the first photo, then Cubase closes, and then the second Photo shows the slave app continues to crash out

for the sake of investigation I installed Cubase Artist 6.5 in 32bit mode to see if 32bit rewire was fixed in that version and I was Right!!! my test was successfull!!! Cubase Artist 6.5 seems to launch any of the versions of Reason just fine, without crashing!

after a bit more testing i saw that ReWire hosting in v6.05 crashed, but after updating to v6.07 it doesnt. so basically what i’ve figured out here is that any version after Cubase v6.0.6++ will work fine

i knew that the v6.0.6 update was when rewire x64 compatibility was introduced,
could it be that the 32bit ReWire was also fixed at that same time??

in my test im observing right now, Cubase Elements 6.0.7 (32bit) playing back from Reason Essential 8.1 (32bit) i was able to bounce audio from Reason to Cubase perfectly.

Try comparing the rewire.dll that comes with Cubase 5 and Cubase 6.07.
I remember there where something with rewire, and replacing the dll that came with Cubase to a newer one fixed that problem. That of cause was many years ago, I don’t remember the details.

anyone else here that has been around since the days of Cubase 5 (2009-2012ish?) that can shed some light on this for me ?

still fairly certain it’s 100% ReWire related. not sure if any of the more recent 64bit Audio Software install+uninstalls I have done on my PC have had any change on the outcome here, but obviously “Cubase Studio 5” was out before the Cv6.0.6 64bit ReWire fix came into the mix in (April 2012), surely they had 32bit ReWire working between the different flavors of “Cubase 5” into whatever Reason Version was current at the time?

*perhaps thats the source of the bug? ie: that the versions i’m using for the ReWire Slave are too new + have some kind of incompatibility in the ReWire Config in relation to the ReWire Host which is “Cubase Studio 5” updated to v5.5.3.651, the exe file of which is dated June 2010 – reason Essentials 8.1 hadnt been released yet obviously, back then, only Reason v5.0 had been released a few months prior, “Cubase 5” having been rolled out initially in 2009.

ReWire has always been kind of a pain in the ass like this, probably why “Reason Studios” chose to put ReWire out to pasture (Retirement of the protocol) but I still feel completely abandoning ReWire wasn’t the best choice. it’s something they could have easily left in + made optional, as well as to remain offering it the Audio Software development community, to pull the plug on the technology completley is affecting everyone with every app.

I guess I should try out the 32bit ReWire again with Reason v5.0 instead and check the results + report back my findings. Would be great to get to the bottom of this if anyone else has any ideas. I was hoping this was a well known bug and that someone would step forward with a link on how to cope with this…

the main reason i want to get this solved is because “Cubase Studio 5” Allows “recording from Busses” like the PRO / Full Cubase License does (Which allows you to set the INPUT of any Audio Track to be the output of a Group Channel Bus,) but I only have an ARTIST level license for the time being, i’m waiting for the next 50% off sale to jump from ARTIST to PRO

sfc/scannow wasn’t recognised on my pc.

It’s OK got it now.
It does revert everything back to the Microsoft settings though

sfc /scannow is something someone does when they are worried their os system files have been corrupted - i honestly dont think that has anything to do with the topic of this thread. but it’s never a bad idea but it’s not going to change the behaviours i’ve described in this thread.

ok i tried installing Reason v5.0 + it worked 100% fine!!! no crash!
i’ve come to realize that none of versions of Reason i was trying before ever existed in the time of Cubase 5 or prior, only Reason 5 existed up till that point, and it works fine!

the Reason 6.5 update happened in June 2012 few months AFTER the cubase 6.0.6 ReWire fixes.

does this mean that only Reason 6.0 (+ below) are compatible with Cubase 5 (+ below)???
as Reason 6.5 works 100% fine with Cubase v6.07+

That’s not possible if you typed it right: it’s part of the Windows Operating system. It looks like you missed the space between the command (SFC) and the switch (/scannow)

sfc /scannow

ok so i just tried Reason Essentials 8.1 + it launched ok now too! no more crashes!
maybe installing Reason 5.0 somehow corrected what was wrong???

not sure how or why but the problem seems to have fixed itself re: launching 32bit ReWire SLAVE inside of a 32bit ReWire HOST

I just tried again, to confirm once + for all,
i launched Cubase Studio 5! and i was able to launch Reason Essentials 8.1 just fine :wink: the problem is fixed!!! Reason 5.0 install seems to have fixed whatever was wrong!!!

actually I remember now getting an error message about a file not having permission to copy a DLL to do with ReWire, but then I just quit, And Relaunched Reason 5.0 “As Administrator” and i think thats when things got fixed.

1 Like