Cubase 5 - No Sound after PC and OS Upgrade

Hello there!

Been using Cubase 5 for years and loved it and can safely say that I do not want to upgrade as there simply has to be a better solution. I upgraded my PC (all parts) and upgraded from Windows 7 to Windows 10, and now I find myself getting no sound in Cubase - not from audio files or midi instruments / Kontakt etc.

In Windows 7 I had a sound card called Asus Xonar HDAV1.3 Slim which I am no longer using since my motherboard (ASRock Z370 Pro4) has a built-in sound chip (card?) and was hoping I’d be able to use that one instead as the Asus Xonar one is almost 10 years old.

So, does anyone have any idea how to get my sound back? Am I missing any drivers or do I simply NEED to use a sound card other than the built-in one in my motherboard?

For information’s sake, my PC is a HTPC which is hooked up to a receiver and a 5.1 surround system and my setup has been like this ever since I first began using Cubase.

I will trade government secrets in exchange for help.

Depends on what you’re doing but you get a lot of functionality and low latency using a real audio interface.

But if a sound card suits your needs then that’s good.

Let’s say you bought an audio interface, it wouldn’t just work with cubase. You would have to download the ASIO driver made for your interface from the manufactures website, install it then point cubase to that driver in VSTaudio.

So a sound card would need similar, I’m not that up on using a sound card for cubase but probably it would be ASIO4all that you would download and use as your driver and set cubase to that.

I downloaded a driver from ASIO4all already and it didn’t fix it. I know I used to have a Generic Low Latency driver and I don’t have that one anymore after upgrading. I’m truly at a loss here.

Downloaded Realtek driver from motherboard’s site. Now I have another choice in Cubase: Realtek ASIO. However, still no sound. When I have ASIO4all v2 chosen, I at least see activity (blue bars moving). There was a list of drivers to download on their site, I figure I may as well download all of them to see if it fixes it.

I just now tried switching from ASIO4all v2 (after testing it again) back to Realtek ASIO and got an error: “Runtime Error! Cubase5.exe. R6025 - pure virtual function call” - no clue as to what this means. Never seen this error before.

Looks like there’s a lot of stuff to try:

Might be getting the drivers to get along in win10. I used to have to run my firewire driver in compatibility mode or something, can’t remember what exactly, just getting old drivers to work in new OS blues.

Another reason to get an audio interface, modern version software made for win10 etc.