Cubase 5 not working in Yosemite

Hi, When I switched to Yosemite on my macbook I can no longer get Cubase 5 to work. I was told I need to wait for Steinberg to issue the appropriate update. Is this true? If so, when might that become available?

I seriously doubt v5 will be updated…

Aloha s, and welcome to the board. E’ Komo Mai’.

All is not lost.

Unless there is really some aspect of Yosemite that you need, (can’t think of one for using Cubase)
consider this approach:

‘Rolling back to Mavericks’.

Here are a couple/three articles showing you how to do it.

http://osxdaily.com/2014/10/22/downgrade-os-x-yosemite-to-mavericks/
http://www.macworld.co.uk/how-to/mac-software/revert-back-mavericks-from-yosemite-3581872/
http://bgr.com/2014/10/23/yosemite-to-mavericks-downgrade/


Good Luck!
{’-’}