Cubase 6 (32-bit) crash on Win 7 (64-bit)

Cubase 64-bit runs fine on my machine, no problems there.

Due to alot of 32-bit plugins (and not using jbridge), I just installed Cubase 6 32-bit on my Windows 64-bit system.

After clicking on Cubase6.exe (32-bit) the splash screen turns up and it starts initialising. Hoewever, it suddenly disappears - it doesn’t start and the blank Windows desktop appears.
After reading some other forums, I uninstalled Microsoft’s Visual C++ 2008 redistributable library and reinstalled it, still no luck.

Any clues?

Probably a plug-in that it doesn’t like.

Watch carefully the initialising text in Cubase window & you may be able to see what it’s initialising as it bombs every time.

Otherwise, the way to check is to move the contents of your vstplugins folder to another folder on the desktop (or wherever)

Confirm that Cubase starts & then close again…start moving blocks of plugs back to the original folder & opening cubase each time…keep note of what you move in (I do it alphabetically so first try a-h or something) As soon as it fails to open move the last block back out & copy in part of it until you track the problem plug.

Sounds more complex than it is…only takes a few minutes.

Probably all you’ll need is the latest update for the offending plug-in to get it working.

Grim, thanks for your reply.

I have found the problem but don’t know how to avoid it.

I used Process Monitor to see which files Cubase 6 is loading on startup and VST scanning.

Silly Cubase, it scans my entire harddrive C and D drive for .DLL files! WHY??

It crashed first trying to use Acronis Trueimage as a dll, then it crashes using Microsoft Visual Studio 8 runtime dll as a VST plugin?? What the hell? How do I disable .dll scanning of Cubase 6 on startup?? That is ridicolous.

Please see the image attached.

Cubase is installed on the D: drive.

After Cubase scanned it’s own plugin folder, it continues to scan my entire D: drive, starting with the first alphabetical folder on the D: drive. Eventually it finds so many .dll’s that the blacklist file grows too big and causes Cubase to crash.

I tried also deleting all Cubase preferences manually (deleting folder C:\Users[username[\AppData\Roaming\Steinberg\Cubase 6) but this has no effect either.

If you have some ideas please let me know.
cub.png

Hello Esabuc,


Is there also an older version of Cubase installed ?

Cheers,

Chris

Chris, I have uninstalled old previous versions (Cubase 5) and also deleted manually the Cubase 5 folder (C:\Users[username[\AppData\Roaming\Steinberg\Cubase 5).
Thanks for your help Chris.

bump Any other ideas?

The way you describe the issue I suspect that an entry in your Windows registry is currently set wrong.
This forces Cubase to scan all folders on the hard drive for plug-ins, which leads to unstable behaviour.

In the Registry Editor navigate to:

HKEY_LOCAL_MACHINE -> SOFTWARE -> VST

There you should see an entry called “VSTPluginsPath”. It needs to be set to:

D:\Program Files\Steinberg\VSTPlugIns

If it set e.g. to just “D:” then Cubase will scan the entire hard drive for plug-ins.

Once you have changed the entry you can close the Registry Editor and launch Cubase.
Now only the default path should be scanned.

Thanks Sebastian! The only VSTplugins path I found on my Win7 64-bit system was:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\VST
(in there is an entry “VSTPluginsPath”)

It was set to D: and I wonder how this could have happened, since Cubase never started in first place to give me a chance to change it??

I have changed the value and it’s all working OK now.
Thanks again!