Cubase 6 doesn't "remember" my Waves plugins

Ever since I changed from XP to windows 7, Cubase 6 doesn’t load my waves plugins that were saved in a project. As a project launches, a list of all of my waves plugs pops up. If I click on one of the particular waves plugin that is being used in the project, it will open as saved. If I click outside the waves pop up list, the project opens without any of the saved waves plugs.

I’ve tried to “update plugins” under the device menu, to no avail. Another forum suggested I have C6 “scan” the waveshell.dll. As of yet I haven’t figured out how to scan said .dll.

Can anyone help me figure this out? I’m running Cubase 6.0.5, 32 bit.


Yeah, I think I get what you are saying but you are not as clear as you might think. Are you running 32 bit Waves plugins? Clear this up.

Can you open the project, load the Waves plugins and have you original project as it was before you changed the OS? This is not clear, but, IF YOU CAN DO THIS, then load the project and save it, and change the name when you do. Sometimes Cubase needs to convert a project to the newer version of Cubase - and here I wonder if you have upgraded your Cubase version when you changed your OS?

The process you describe, how Cubase offers you a window to choose the plugins as you load a saved project? I have never experienced that. ?? So maybe there is somebody else who has or you are not explaining the process correctly? I upgraded my OS from XP to Win7 and I have opened old projects without your issues, but then I went to 64 bit and upgraded my Waves to 64 bit, as well - and DID NOT have any Waves plugs loaded in them. I pretty much turned a new page here, saving my audio files and rebuilding as needed if I had to. Eh, not what you want to hear maybe but I knew going to Win7 64 bit was going to be a unique experience.

Yes, these are 32 bit waves plugs. I can open a project and load all the waves plugs I want. I have renamed many times, as I do that anyway whenever I make changes to a mix, so I can go back to my older mix if I’m not happy. A guy over at the gearslutz forum stated that he’s having the exact problem, only with an Apple computer.

That forum is the one that told me I need to “scan the waveshell.dll file” so Cubase can “learn” the path, only I have no clue how to do that. I’ve tried to " update vst2 path " under the plug in info dropdown menu, which did nothing. I’m still stumped.

I didn’t upgrade Cubase after I upgraded my OS, so it seems its a Windows 7 issue.

Any clue what else I can try?

Well, im pretty sure the Waves folder you refer to is in the Windows 86x folder under Waves, even for 64 bit. Are you on the V9 cloud with your Waves? If you are flying old school with Waves, not running with the new Waves V9 installer this may be your problem. Fill me in.

I suppose I’m “old school”. I only use a few of the plugs out of the bundle, but I use them in every project. Again, all worked perfectly in XP, with the same version of cubase as I’m running now, 6.0.5.

It most certainly has something to do with windows 7 it seems.

Marc Robertson

I don,t know if this will help you ,but i was having authorisation problems with my Waves stuff.So,i wrote to support.They told me my problem was a known issue to be fixed in a later update.The solution now is to buy a usb key and put your licenses there.I stopped having trouble.Everything runs perfect.
Perhaps you should mail Waves support see if its a related problem ?

Cheers Violetice.

Hm, OK, you didn’t say if you were on the V9 cloud setup for Waves. Are you? The USB key is what I use with my waves, as the last poster suggested. But this is all about the V9 system. Are you V9?

I’m still using 4.0,…haven’t seen the need to upgrade as its been working fine up until I upgraded to Windows 7,…I suspect that’s got to be the problem. I still find it odd that Cubase will let me load the plugs,…it just won’t save them.