Cubase 6 w/ Focusrite Saffire 6 - no sound?

I got a brand new Focusrite Saffire 6 USB and did the following:

  1. Installed newest drivers from Focusrite website.
  2. Connected Focusrite device via USB 3.0
  3. Was able to hear music coming from L/R out of Focusrite (windows sounds, WinAmp, etc)
  4. This is currently the only audio device enabled on machine, so I set it to “Themes: No Sound” and checked both boxes under Exclusive Mode in the advanced settings (“allow applications to take exclusive control” and "give exclusive mode applications priority)
  5. I opend Cubase 6.
  6. In Cubase 6 under Device Settings > VST Audio System, I set the ASIO Driver to Focusrite USB Audio Driver.
  7. In VST Connections > Outputs, I see:
  • Bus Name: Stereo Out
  • Speakers: Stereo
  • Audio Device: Focusrite USB Audio Driver
  • Device Port: Left > Output 1 and Right > Output 2
  1. I imported an audio track. It renders the audio track, and I press play. I see no meter activity on the output section of Cubase 6.
  2. I switched the ASIO Driver to ASIO DirectX Full Duplex Driver
  3. I see meter activity and get sound from the Focusrite. Nice. Love that 2048 sample buffer size.
  4. Switch back to Focusrite USB Audio Driver, no meters, no sound.

Any ideas on this one?

Thanks for the help.

Problem solved. It simply hates the USB 3.0 ports. Too bad. I plugged it into a regular USB port and it worked.

Hi Shane - glad to hear. Just so you know, tech were stating they were working on a new Saffire Driver (currently 2.2) . I have an issue with my MIDI plug not working on my Liquid mix channel - I solve it by using USB/MIDI cables available cheaply on Ebay.


I love u

Have spent two whole days trying to solve the same problem.
Did not know that I even had usb3 on my computer.

/ Fredric


Just spent 4 days scouring the internet after having installed a new SSD. I just randomly stuck USB cables back into my PC afterwards and have been pulling my hair out ever since!

Just switched a couple of USB cables and sanity has been resumed. I guess USB1 devices aren’t that compatible with USB3.