Cubase 7.5. MACRO for open Key Editor in zoom full ?

Hi,

I’m trying to set Marcro first time. But it didn’t work as I want.

I want to:

  1. open key editor (double click)
  2. zoom full (shift + F)

Result: key edit window open and edit range is centered. On the left and right, there are some borders space to click on timeline. I mark these borders on pic by green arrows:

https://dl.dropboxusercontent.com/u/78857404/key%20editor%20borders.png

I don’t want to assign another “key command” for that. I want, after double click to show edit window with zoom full (shift F) behavior.

Is this possible that or other way ?

Thank you.

I want, after double click to show edit window with zoom full (shift F) behavior

What your picture shows is shift F behaviour. Try it without the macro and you’ll get the same result exactly…no??

You’re right. It is Shift F behaviour. But I don’t want to click Shift F EVERY time when I open Key Editor. I’d like to Cubase do it automaticly. Wha it is so important. Because Cubase have very bad windows menagment. Edit windows hiding after clicking somwere beside that window. If I need to point cursor in earlier I use a timeline in Key Editor window. Bu if there is no left borders it s hard to click there (because there is name of event in this place).

Schermafbeelding 2014-02-24 om 18.10.25.png
Hi,

I just made the macro that you want and, for me, it seems to do exactly what you want.
But maybe i missed something in your wish / comments.
Please let me know if this works for you too.

(BTW: I am on mac, but i don’t see why my example macro wouldn’t work on Windows)

Best,

Robbie

OK I misunderstood…I thought the picture was showing what your macro had already achieved…not what you wanted to achieve.

So Vanhaze macro works perfectly for this on Windows too.

Thank you Vanhaze. It works ! Unfortunatly only when I hit return key (not for double mouse click). Can it work with mouse double click somehow ?

Macros are initiated with key commands…you can’t assign double click to open it.

You can of course assign it to any other key/modifier combination you want in the top panel of the key commands window.

"Thank you Vanhaze. It works ! Unfortunatly only when I hit return key (not for double mouse click). Can it work with mouse double click somehow ?

@ Serenity : Yes, i am aware of the fact that mouse double click doesn’t work.
Sorry, i am the kind of guy that tries to avoid mousing as much as possible (“mouse-arm” :cry: )…

Maybe a tip for you too ? :smiley:

Best,

Robbie

Yes. Thank you guyz for your help. Now, maybe I need to suggest that case to Steinberg. Maybe they add option to leave borders when opend Key Editor.

That’s a good idea.
Maybe they can implement this feature as a Preference On/Off setting.