Cubase 7 and Juno-Di Midi Error

Greetings Fellow Cubase 7 users!

First of all I’d like to apologize if I posted my concern in the wrong section. I’m still new here.
I’m trying to do a midi setup for a ROLAND JUNO-DI Keyboard but was unsuccessful. I’m using an M-audio Uno 1x1 Midi interface which is connected to the Juno Di. For my output and recording audio tracks I’m using a steinberg CI2+ Audio Interface.

My issue is when I add a midi track and try to record some midis, I can’t here any sound… Tried turning on the monitor… Still no sound. But when I try to add an Instrument track and using CUbase 7’s Track presets it works… But when I chose midi track and VST Instrument… No Sound is coming out…

I’ve been doing this for 2 days now without anysleep! T_T Please HELP ME!!! PLEASE!!! T_T I JUST WANT TO MAKE SOME MUSIC… I HAVE FRIENDS WHO ARE COUNTING ON ME… I REALLY NEED YOUR HELP GUYS… PLEASE LEND ME SOME ASSISTANCE! :frowning: :frowning: :frowning:


Sincerely Yours,


Manoi

Read carefully the section about setting up MIDI in the manual (Pg. 19)
It sounds to me like you’ve not set up the local on/off or MIDI thru either in Cubase or in the instrument correctly.
You have to decide if you want to record the Juno itself or want to use it to control some other (e.g. VSTi) Instrument. Then if the Juno you need to decide if you want to trigger it being played from the keyboard on the instrument directly or have it triggered from Cubase.

Thank you for the quick response… I have read that part of the manual sir… and tried the turning on and off the Midi thru active and local on/off and turned on/off setting in the Juno… But still the same… I can use the Juno if i add an instrument track… My problem is getting sound from the Juno and using the juno as a controller for VST instruments too… It show that it is active and u can see it displays something while recording but no sound is produced/heard. Turned the monitor on and off, still no sound. Checked and Unchecked timestamps in device setup… no sound… tried also exporting still no sound… Any ideas?

http://i1246.photobucket.com/albums/gg620/uel_boholano/Midi.jpg

as u can see in the pic… there is activity in the midi track… But I can’t hear any sound…

Perhaps then I was looking at this from the wrong perspective.
Perhaps the thing is, you need not only a MIDI track, for recording the performance, but you also need an Audio track to which the output of the Juno is routed. An Instrument track in effect does just this.
Perhaps you might also look into setting up an “External Instrument” in the VST connections panel.

But I can’t use the sound from my Juno if I do use an instrument track is that correct? or is there a way to use the sound from the juno and place it in an instrument track?

Check out external instruments as mentioned. (Man.Pg 34)
Your Juno will then perform as a VSTi.

Thank For the suggestion sir… But I got one problem I only have two outputs and two inputs. It says their that it requires atleast one extra input and output… T_T and I tried doing that…but now the midi isn’t working or has no activity…

The limitations of your interface are going to be a constant problem when your dealing with signals from multiple sources simultaneously. You have a couple of options though. Either replace the interface with one that has more ins and outs, or add a small analog mixer in front of your interface. I ran a small 4 channel mixer for a while, then later went to a 24 channel mixer and ran this way for a long time. This setup is fine for personal use where you really only need to record only a single track at a time from different sources. A single MIDI in-out is another limitation, but can often also be gotten around. Again if you have more than one MIDI instrument you’ll only be able to record one at a time, but playback should not be such a problem provided your instruments have Thru outs. The audio from each instrument goes to a separate channel on the mixer and is heard through the monitors (which would be connected to the Mixer outs) oblivious to what signal if any is going to a track in cubase over your interface. If this concept appeals to you we can discuss it in more detail if necessary.

For now lets look at your problem afresh.
Forget External Instrument and everything else suggested previously.
What you need is 2 MIDI connections between the Juno and the interface (crossed in to out, and out to in as usual). This will facilitate midi data to be recorded to a midi track in cubase, and similarly allow these same signals to be transmitted back to the Juno. Once the midi is recorded. you no longer require the midi cable between the juno out and the interface in!
With MIDI Thru Active in Cubase Prefs, and Local turned off on the Juno; with headphones or monitor speakers connected directly to the Juno, you should be able to hear it playing. If you want to record the audio from it then you need to connect the audio out of the Juno to the Interface In and record the signal on an audio track. (Once the audio is recorded, the midi track can be deactivated!)
If you have your monitors connected to the Interface outputs then to hear the Juno you will need to activate the monitor button on the Juno audio track (once recorded this button should then be deactivated).
If you were to use a mixer in the above case, the Junos audio would be connected to a given input(s) on the mixer, and these routed to the monitors. Pressing a record button on the mixer, or routing to a sub channel or send (this depends on the mixer) would route the signal to the audio interface for recording. The interfaces output is also sent to the mixer via a dedicated mix or listen input or standard inputs and thus to the monitors.
I hope the above makes things clearer, and not cause more confusion.