Cubase 7 & Latency Issues

Hi Guys,

So before i start i’ll give a brief of my PC and Hardware to clear things up hopefully:

Windows 7 64bit, Intel Quad Core Processor 3.2ghz, 8GB ram & 1.5 TB drive space (60% available).
M-Audio Fast Track Pro
M-Audio Axiom 49 2nd Gen.

My issue is this prior to last week i had no latency issues with midi in Cubase 7 but all of a sudden this i week have and when recording in Midi it is enough to put me off playing piano or nay other instrument, according to my control panel i have 5.3ms latency which isn’t a lot but it seems to be more than this any ideas?

Kind Regards
Rick

If you need any other information please ask (very new to the very technical stuff be kind :smiley:)

Snapshots:


Vst Audio System.png

Other Pic
M-Audio USB ASIO Panel.png

And that L3 in the master insert has how many samples plugin delay…?

Sorry are you saying the L3 creates a delay for the rest of the Midi?

Removing the L3 on my output has resolved the Issue thank you! i didn’t think this would cause delay is there a reason for that, could please explain so that in the future i can avoid such errors?

Plugins in the mon itorin chain create a delay in the monitoring chain. Question is how big is the Plugin delay. I don´t have waves L3, so I can´t tell you.

I think it is expalined quite well in the manual -> monitoring via Cubase / direct monitoring.
In short: a plugin needs time to calculate and Cubase has full Plugin delay compensation, therefore all signals get delayed the amount of the “slowest” plugin, so all signals are delayed the same and are therefore in sync overall.

It was significant enough for me to struggle paying in midi, i probably would have said 2-3ms of extra delay, i will remain to keep it off until i decide to do the final mix a track.

You can read up on “constrain delay compensation” also, but generally it´s a good Idea, top keep the “heavy” Plugins for the final mix

This is not directly related to the problem you have had but you’re on W7 so you should have Steinberg Audio Power ticked in the Device Setup (your first picture). This prevents Windows from throttling the CPU (as part of its energy-saving features), which can cause Cubase to prematurely overload.

It is an option, so maybe there are setups where it is better not to use it, but you can easily see for yourself by monitoring Cubase’s internal ASIO meter (F12) with and without it.

See this KB article, paragraph 10, which was written when this option was called “Disable CPU Energy Saving”: https://www.steinberg.net/en/support/knowledgebase_new/show_details/kb_show/optimizing-windows-for-daws/kb_back/2020.html

Oh, and seeing as you’re new to this, don’t forget that for mixing a high latency is better - it reduces load on the system. You only need low latency when recording.