Cubase 7 VSTs can't be heard

Hi, I’ve been trying to assign every possible way my vsts to my audiobox usb or to stereo outs, trying to play on my external keyboard with midi and audio cables correctly assigned, and no Vsts sound may be heard, it’s still the sound of my original keyboard that can be heard. Any help about how I could assign correctly to hear my vsts sounds? I’m using cubase 7 Elements.

Things done:
Been in device setup, changed driver in control panel to Audiobox USB from the first one generic that was already not working to make vsts sounds. Genereic low latency drivers are still shown in the main page under VST audio system. Tried then to put in VST ASIO output to put Audiobox USB didn’t worked, no other choices than that.

Changed every possible way in the in and out section under the audio or vst section on the left of the screen, Audiobox USB, stereo, Mono, nothing worked.

When I record the vst voice (ex. Absynth 5 or FM8) The part is recorded and it plays the external keyboard not the vst sound.

Any help appreciated very much

Thank you

I’ll take a guess as you don’t list any specs for what keyboard or what computer OS you are using…

Generally speaking your keyboard will be connected to the computer using a “MIDI to USB” or “USB (A to B)” cable.

  • Connect your keyboard to the computer before starting Cubase (Cubase 7 won’t recognize it if it is connected after CB is started). Make sure your computer recognizes the keyboard.
  • Turn on the keyboard.
  • (Most likely, this is the step you are missing) Set the keyboard midi function to “Local Off”. Check the keyboard manual to find out how to set it to “Local Off”.
  • Start Cubase
  • Open an existing or new project.
  • On an instrument track (not midi) choose “All midi inputs” in the input routing field (this setting is in the track inspector section.
  • Just below that in the track inspector section choose a VST instrument like Halion Sonic SE and choose a sound from what is available.
  • Enable the track “Monitor” (button looks like a speaker) function and now you should be able to hear your keyboard thru the monitors or headphones connected to the UR.
  • Record something. To hear what you recorded you must disable the track “Monitor” function.

Regards :sunglasses:

Thanks a lot, it worked! :smiley: