Cubase 7 w/ Tascam FW-1884

Could someone explain the necessary steps to configure cubase and tascam fw-1884 so that they will work together nicely? Cubase 7 sees the FW-1884 ASIO driver, but no sound goes to the tascam, and the controls don’t wok (I have configured mackie control in both FW-1884 control panel and in device setup in Cubase.


Wish I could get that far. Just plugged in my new (second hand) FW-1884, patched in all my instruments, did all the necessary in the control panel for the FW, open Cubase (6.5 on win7 64bit) and… cannot find ASIO driver. Boo. Still, I’ve only just started my troubleshooting (by looking at this post for one), but if you find any pearls of wisdom, then please share.
Right, better go and trawl the web for answers. I’ve one or two ideas what it could be. Doncha just love web trawling for advice on making unfamiliar kit work? Way more fun than filter sweeping a deft bassline…
Ta much.

Could be the new firewire driver from Win7. Try the legacy firewire driver. If you don´t know how, google legacy firewire driver. My focusrite liquid mix also needed that.

Well the firewire indicator light on the FW-1884 doesn’t light up. I’ve had trouble with this in the past when I actively used the FW-1884 and Cubase 5 (connections would drop). Investigating on the internet has yielded that the FW-1884 really requires a firewire input card that uses the TI (Texas Instruments) chipset. Also, my firewire cable is old and could be bad. So I ordered a TI chipset firewire expansion card and new high-quality firewire cable. I will post again once I try with these items.

I have a FW1804 and it is fine with via chip too, but on win xp. If any issues remain please try legacy driver. Microsoft really broke something there and if audio drivers are not updated like these old Tascam units, legacy driver is the cure.

Installed the pci firewire card with the TI chipset. Connected the new firewire cable from the expansion card to the fw-1884. changed the 1394 driver to the legacy driver and rebooted. Powered on the fw-1884 – now the firewire light on the fw-1884 lights up.

Started Cubase and loaded a project. Changed the ASIO driver to ASIO FW-1884. Set the VST Connections for stereo output to channels 1 and 2. Played the song – no audio levels in Cubase or on the FW-1884.

The FW-1884 is configured to Mackie Control Emulation. I added Mackie Control under Remote Devices and set the MIDI input and output to FW1884 Control.

Adjusted the faders in Cubase – the faders on the FW-1884 responded in kind. Tried adjusting the faders on the FW-1884 – no response in Cubase.

I even tried the ASIO4ALL v2 driver. Same results: Cubase can control the FW-1884, but not the other way around. And there are no audio levels in Cubase or on the FW-1884 during playback.

Anything I might be missing here?

I have the FW-1884 with 2 FE 8 extenders and it works find except for a faulty fader in one of my fe-8’s. Everything you are saying that you’re doing is exactly what I would have asked you to check. It should work fine. The only difference with me is that I do not use the audio from my tascam. I have an MR-816 as my sound card. Not sure if there is something with the fw’s drivers thats causing this. What driver version are you using?

Open VST Connections and turn your Control Room on, select your output channels from the pull down list. I will assume you have your inputs routed in the mixer?

If you see the blue audio indicator pulses in your channels and your output channel, you will have audio out.

P.S. The Win7 FireWire driver is not a problem that I have experienced - MS did fine by me. And yes, I, too, run a TI chipset on a PCI card in my desktop.

Mooger - If you installed the ASIO drivers properly then Cubase will find them. Did you install the drivers? You need to keep installing them until they show up on your device in the Device Manager. Then open Cubase.

I am posting it because I didn’t find good information regarding the FW-1884 and Cubase.

After trying many options to configure the Tascam FW-1884 with Cubase 11 Artist I found the wait to use the EQ Controls from FW-1884 to have full control of Cubase EQs.
I used the following configuration:
1- Studio> Studio Setup
Add Device Mackie Control
2- Studio> More Options> Mackie Control >> choose Compatibility
3- Set Control Protocol “Cubase SX / Nuendo” on FW-1884 Control Panel (FW-1884 v.1.80 Windows 7 with compatibility to Win10)

To activate/deactivate the EQ use CTRL+ and chose the frequency and adjust using the 3 controls (Gain, freq, Q).