Cubase 8.5 Won't Display Arranger or Mixer etc.

Here is a weird one. I installed Cubase 8.5 update and placed it in its own directory so that Cubase 8.03 was not affected. After launching Cubase 8.5, none of the predefined 8.5 projects or templates will open. Even when selecting new and starting a project from scratch no mixer or arranger appears. Oddly enough when I open a cubase 8 project using the open menu in Cubase 8.5 the projects loads and plays as expected with all windows displaying as expected. Cubase 8.03 continues to work as expected. Any ideas on where to start with this…

I am on windows 7 64 bit with a rock solid hexicore 3930K i7 processor.


Try to call any of Workspaces from the Workspace menu, please.

Aren’t all windows minimized?

Hi Martin. The workspace menu is blank. I tried to restore windows but nothing. I am guessing that something went wrong with the install. What do you think?


Could you try to trash the Preferences of Cubase 8.5?

HI Martin. I trashed the preference the behaviour is the same. I uninstalled 8.5 update, redownloaded it and tried again… no joy. It still won’t open any of the windows unless I use the open menu item and navigate to an older project. My system is rock solid and I am quite competent with Cubase (since Cubase 3.7) . My setup is pro rig with dual RME raydats with a ton of dedicated and mapped IO. I have never had this kind of issue with Cubase. My Cubase 8.03 is working as it should (just the documented issues) so I am at loss.

Is it possible the Cubase 8.5 needs to be installed in the same directory as the Cubase 8 folder? I put it in its own directory so that I could use 8.03 if 8.5 was glitchy. Do I need to install 8.5 over 8.03?


Cubase 8.5 is another full application. You don’t need to install it to the same folder as Cubase 8.0.3. You even don’t need Cubase 8.0.3 to install Cubase 8.5.

Do you have your Cubase 8.5 in some user folder? Different from the default one? Maybe even od drive D?

The Workspaces menu shouldn’t be blank, of course. There are some factory Workspaces.

Martin. I just launched Cubase 8.5 by clicking on the .exe file directly When launched directly (not using the shortcut on the desktop) the application and all windows opened as expected. All the templates load and all appears fine. I quit the application and clicked on the desktop shortcut and launched Cubase 8.5 as before and it now works as expected. This seems very odd behaviour. I am happy but damn if I know what caused this to mess up in the first place. Weird. I didn’t change a thing other than to launch it directly from the exe file once and only once and it fixed the issues. Is there an explanation for this?

I have another question that I will post in regard to migrating some of my external synths and effects routings that I will post after I have fun exploring the new features.

And by the way thanks… Although I don’t often post here as the solutions are often already covered I see your helpful advice all over this forum. I know that we all really appreciate it. Thanks so much. - Scotty

Hi Scotty,

Thank you for the info. I’m glad it works to you.

There is a known issue with the double-click to the Cubase icon, and opening the project directly from the desktop. In this case, Cubase 8 opens instead of Cubase 8.5.

I’m thinking if this could be somehow linked (even if I cannot see any link here).

Ok I have determined why the issue occurs. IF you set Cubase to prompt for file location when creating a new project and set it to “Computer” instead of a more specific and viable file location it won’t open up the windows or populate the workspaces menu. I can replicate every time. Solution is simply to set Cubase to prompt for location on a specific file folder.

Interesting… What Windows version do you use?

Windows 7 ultimate 64bit Service Pack 1

OK, I will have a look.