Cubase 8 Artist - can't record MIDI sysex

I have a Mac mini SSD-based system with external Presonus Firestudio interface and two hardware synths, Roland MT32 and JV2080. I usually record the synth settings in the Project via sysex.
I have just upgraded from Elements 8 to Cubase 8 Artist :frowning: . I have repeated the download and incorporated the latest update, but this bug is still present in the new installation and not in Elements 8.
I have disabled all previous Preferences folders.
The bug appears in old and brand new Cubase Projects, and seems to be independent of various record, metronome, SYNC and other settings.
Strangely enough, incoming MIDI from Atari, including sysex, is recorded!

  1. Prepare the JV 2080 synth to output its settings as sysex.
  2. Select a MIDI track in Cubase and enable Record (in fact, it’s enabled by default).
  3. Click the *** asterisk** key: Record starts
  4. Click Execute on the synth and wait until a “Complete” message indicates that the sysex transmission is finished.
  5. Inspect the recorded MIDI, checking for Sysex. Currently, only a single Bank change message is recorded.

I posted this, and since it’s not a bug I apologise to Steinberg!
It seems what I should have done was uncheck the sysex filter in Preferences\midi! Once I did that there was no problem.

My only excuse is that this setting wasn’t necessary in Elements 8.

Anyway, it’s SOLVED and I leave it to the moderator to decide whether it’s worth keeping the post.

1 Like

that was it. Thanks