Cubase 8 .cpr file association

I’m new to the forum and any help would be appreciated. I cannot open Cubase 8 from my saved .cpr files as the .cpr files default is associated with windows shell common dll. I tried associating the .cpr files with Cubase 8. In default programs (control panel) but the cpr file is missing.

I uninstalled and reinstalled Cubase but made no difference.

If I start up Cubase from the Cubase exe. I can then open the cpr files from Cubase and all works ok.

Hope someone can help !!!

I hope I have posted to the correct place in the forum.

For the windows operating system you can right click on the .cpr file and choose the option “Open with…”. It is there where you can choose Cubase 8 or whatever program you want to associate with opening .cpr files. After you do that the version of Cubase you associated to it will open when you click (or double click) the .cpr file.

Regards :sunglasses:

Thanks for your reply, I appreciate it. I have tried right click on the .cpr file but the Cubase icon does not show up in any of the recommended programs so I have to go through the system and find the Cubase exe file in the Steinberg folder, when I click on that it will then open. I put a tick in the box for always use the selected program to open this kind of file but it won’t associate it with Cubase on the next occasion and it’s back to square one.
I think I might have a problem somewhere in the registration files ?. I am using win 7 and Cubase 8. I have had similar
type problems before but always managed to sort them out but not this time.
Thanks again for your help.
Maugein1

Make sure your Cubase 8 is set to “run as administrator”. If not, set it and try again.

If still no good…

Take a look at this Microsoft video to see if you have set Cubase as the default program. Then maybe you will be able to associate .cpr files to it (or maybe that will actually make the association for you). Let us know if it works. Thanks :wink:

http://windows.microsoft.com/en-us/windows/change-default-programs#1TC=windows-7

Regards :sunglasses:

I tried running Cubase as administrator and watched the Microsoft video. I tried associating the .cpr files with Cubase 8 in default programs (control panel as per Microsoft video) but the .cpr file is not present in “associate a file type or protocol with a program” and I think it should be there.

It could be a problem caused by a corrupt registry entry and may need a new entry to correct it ?. If I start Cubase with the Cubase exe and then load any of my .cpr files from the Cubase file menu everything works fine, the .cpr files even display the Cubase icon when viewed from the Cubase file menu but outside of Cubase the .cpr files are displayed with the windows shell common dll icon.

I don’t want to restore the computer to an earlier “pre problem” date if I can avoid it as I’m not sure of the time the problem started, I can manage when operating the .cpr files from Cubase file menu but it would be good to have it working property.

Thanks again for taking the time to respond to my post.

Best regards

Hello,

please try this:

– Right-click on a .cpr file
– Select ‘Properties’
– Under the ‘General’ tab, click on ‘Change’
– If Cubase is not in the recommended applications list, please click on ‘Browse’ (bottom-right)
– The Program Files folder will open, please direct Windows explorer to this location:
Program Files -> Steinberg Cubase 8 and select ‘Cubase8.exe’

This should work without the need to correct any registry entry, hope it helps.

Hello Fabio,

Thanks for your reply. That was one of the first methods I tried, I right click on the .cpr file and go right through to Steinberg “Cubase8 exe.” and select it, that loads up Cubase 8 but when I switch off and come back again I am back to square one. I make sure to put a tick in the box for “always use the selected program to open this kind of file” but it still won’t associate the .cpr file with Cubase. It still shows “windows shell common dll” as the default for the .cpr file.

I have spent hours trying to find a way around it and checked out all suggestions I could find on the Internet.

I can run Cubase 8 on my laptop with no such problems.

I appreciate your help Fabio.

Regards,

Oh, sorry, I didn’t get you tried that already (and didn’t check the MS video which requires Silverlight, BTW :wink: ).
That is weird, especially if you are using an admin profile.

If both that and trying to associate the files extension in ‘Programs -> Default Programs -> Set Association’ didn’t work, I’m afraid you are right in thinking it might need a registry manual fix (can’t really remember where this stuff is on top of my head, sorry). But I’d think uninstalling and re-installing Cubase (the application only, not the plug-ins, extensions and Content) might be faster - that should also re-assign the cpr extension to Cubase.

Thanks for your reply Fabio, I tried uninstalling and reinstalling Cubase 8 and had no success I then uninstalled Cubase 8 and all the applications that go with it and even cleaned out any reference to Cubase or .cpr files in the registry and reloaded but again it made no difference, so it must be a problem in the registry. If I can’t get a registry fix I might have to try a restore to a date before the problem appeared but I would prefer not to do that.

Thanks again for your help Fabio.

Regards

Hello,

sending you a PM.

Cheers,

Hello Fabio,

I checked that out but found the value to be the same as in your PM, I re-entered the value but it made no difference.
Thanks again for your help.

Best regards,

The only other thing I can can think of is that you have the Cubase security setting messed up. That is found on a tab after you right click the icon. Go to the security tab then advanced, then change permissions. You will have to look around there to make sure you have the take ownership permission to make certain changes.

If that doesn’t help… sorry I’m out. Good luck and don’t forget to let know how you get this sorted. Thanks :wink:

Regards :sunglasses:

Thanks Prock for your support and also thanks to Fabio.

Regards,
Maugein1

Can you check if the following keys are also there, please?

HKEY_CLASSES_ROOT -> .cpr
Value: Cubase8.Document

HKEY_CLASSES_ROOT -> Cubase8.Document -> shell -> open -> Command
Value: “C:\Program Files\Steinberg\Cubase 8\Cubase8.exe” %1

I really can’t think of any others.

Cheers,

Hello Fabio,

Thanks for your reply. I checked the registrations out and both entries are ok. I think my problem is caused by windows updates as I turned on auto updates a few weeks ago (I normally work offline) to get ready for the free Win 10 download. I had a problem with some of the updates and that I think started off my .cpr problem.

Fabio it’s my intension to update to Win 10 once all issues with Cubase 8 are resolved so I will leave well enough alone and do a clean install then. I can still work away with no problems once I load up from Cubase8 exe.

Kind regards,
Maugein1