Cubase 8 PRO doesen't start on Win 7 Pro.

:smiling_imp: Hello everyone!

First of all I want to say that it’s mental that after buying a new original program it’s impossible for some users to even start it.

After installation (done 3 times, step by step with user manual - which as we all know it’s not so complicated) when I want to start Cubase 8 Pro, after double clicking on icon, the only reaction of my machine is the change of cursor for couple of seconds. Task manager shows that Cubase start for maybe 5 seconds, but then nothing happen. Nothing.

My machine:
CPU 4 GHz i7 4790K
WIN 7 PRO 64.

Everything is new. Machine came out of the box 2 days ago. Same as Cubase. Fresh out of the box.

That is why I’m soooo angry at you Steinberg guys. Please help.

Best Regards.

Make sure your win7 is up to date. Also the .NET part of windows.
Make sure the eLicencer software is up to date, and the license is on the dongle.
Update CuBase to 8.0.20

Everything done as you wrote Sir!
Still no luck.

32bit version works perfectly…

New PC…
all Windows updates Online installed?


Still no luck.