Cubase 8 with Mackie MCU Pro issues

I’m using a Mackie MCU Pro which worked fine with Cubase 7.5 but it seems some behaviour gets messed up with Cubase 8…

  1. It lists all channels, incl. Input channels and the Main Mix. With Cubase 7.5 this was not the case.
  2. The bank buttons now switch block-wise and not channel-wise, i.e. when pressing the Bank buttons a whole page of channels is shifted instead of a single channel.

Are these issues already known? This worked really well in Cubase 7.5 but in v8 it’s very messy now.

Yes.

Reported Here: http://www.steinberg.net/forums/viewtopic.php?f=226&t=69759#p403818

And Here: http://www.steinberg.net/forums/viewtopic.php?f=233&t=69839#p404170

A BIG Issue for me.

Hugh

Change the Mackie Mode from the Devices Menu :wink:

I’ve tried both modes.
Neither fixes the problem.

I’ve also started with a fresh project created from scratch in 8.0.

No fix.

I’m really surprised your MCU is working because I have not heard from a single other person who’s MCU IS working.
And the issue is consistent with everyone.

You do understand my issue, correct?
When I delete channels from the Mix Console Using the Visibility Pane they remain visible on my MCU.
You are saying that you can hide 1 of 8 Audio Tracks Using the Mix Console Visibility Pane and they DO disappear from the MCU, right?



I CAN delete channels using the “Channels Types” drop down menu on the Mix Console and they DO disappear from the MCU. Just not the Visibilty Pane.

Hugh

We had the same issue with the release of C7.0.0 which was later fixed in a maintenance release. I just hope they don’t take too long to fix it with C8.0.10

In the visibilty pane turn off the Input group not just the individual input channels, same with the outputs.
My recomendation to use the compatible mode of the Mackie was based on your second 2nd observation.

Issues im still javing is when i create a new project my mackie mixers get confused… to top it off when i delete and recreate it pits back the cached setting… any help